Warn the user that some websites will not function correctly when activating click to play

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
enhancement
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: Lex Robinson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
As per comment stream in Bug #711618, some users are confused when click to play is activated.
Given that some users specifically want to disable some sites that others specifically do not want to, a shipped automatic whitelist is impractical.
I would therefore suggest that the user is notified that some websites will cease to work as expected/intended while click to play is active and is given an option to whitelist common sites such as youtube immediately after enabling the option.
(Reporter)

Updated

6 years ago
Depends on: 711618
(Reporter)

Updated

6 years ago
Depends on: 549697
No longer depends on: 711618
I don't think we need this anymore with the reworked click-to-play UX that is currently underway.
That UX offers activating plugins long-term or short-term (i.e. while the user keeps using the site), so most remaining visible problems (like e.g. the youtube playlist use-case) will be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.