Search needs a 'no results' page

RESOLVED FIXED in M3

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: st3fan, Assigned: sfoster)

Tracking

x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
When there are no search results, search shows a blank page. We need something more interesting there. Maybe with some suggestions?
(Reporter)

Updated

7 years ago
Assignee: nobody → gbrander
Created attachment 615336 [details]
mockup

Here's a mockup of how we might handle this - 

"No results" message, and buttons to return to the homepage or start a new search
Comment on attachment 615336 [details]
mockup

looks good to me.  it tells the user that the system/app is still working and that what they typed didn't break anything.  thanks for filing the bug stefan.  thanks for the mockup, ian.
Duplicate of this bug: 687509
Duplicate of this bug: 733252

Updated

7 years ago
Target Milestone: --- → M3
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Assignee: gbrander → sfoster
(Assignee)

Comment 5

7 years ago
Fixed in https://bitbucket.org/mozillapancake/pancake/changeset/23665b950370
See empty-search-results branch for details.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.