Closed Bug 745209 Opened 8 years ago Closed 8 years ago

Bug 731494 broke non-tinderbox Linux-64 builds: nsinstall cannot create symbolic link dist/bin/modules/services-common/async.js: Bad address

Categories

(Firefox :: Sync, defect, P1, blocker)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla14

People

(Reporter: justin.lebar+bug, Assigned: gps)

References

Details

Attachments

(1 file)

I get the following error when I build (Linux 64, full clobber build):

  nsinstall cannot create symbolic link dist/bin/modules/services-common/async.js: Bad address

I bisected, and the first bad rev is

  http://hg.mozilla.org/mozilla-central/rev/579f1d93

which is bug 731494.  froydnj is seeing the same problem on his Linux-64 machine.

My mozconfig:

. $topsrcdir/browser/config/mozconfig
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../debug
ac_add_options --srcdir=../src
ac_add_options --enable-trace-malloc
ac_add_options --enable-debug
ac_add_options --disable-optimize
ac_add_options --with-ccache
mk_add_options MOZ_MAKE_FLAGS="-j16 -s"
ac_add_options --enable-application=browser
Blocks: 731494
"bad address" sounds like a C standard library error message and thus a bug in nsinstall. Wut?
Yeah, somebody is passing symlink a NULL.
Gregory, this blocks any developer on 64-bit linux (of which there are lots) from building m-c. Please either fix this asap, or back out the landing in bug 731494 asap.
Assignee: nobody → gps
Severity: normal → blocker
Priority: -- → P1
I wonder why we don't see this on tinderbox...
Yeah, that's indeed odd. But what's most important here is to get people unblocked. If someone can't figure this out in minutes, not hours, someone needs to perform a backout here IMO.
Attached patch Hopeful fixSplinter Review
Still testing this locally. First to review wins. Will land after I or someone else verifies.
That change fixes it for me; my builds are non-clobber, fwiw.
Severity: blocker → normal
Priority: P1 → --
Comment on attachment 614829 [details] [diff] [review]
Hopeful fix

wfm.  I'm not r+'ing because I have no idea what this does.  :)
Attachment #614829 - Flags: feedback+
Resetting flags that I borked.
Severity: normal → blocker
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/018cac438918
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
Thanks for the prompt fix!
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Target Milestone: mozilla14 → ---
It seems to be accidentally-reset-bug-flags day. Pin it on Bugzilla...
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla14
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.