[pancake] Allow environments to send data to the statsd service in phx

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: oyiptong, Assigned: solarce)

Tracking

Details

(Reporter)

Description

6 years ago
We want to collect data in our server-side applications, and as such, I'd like to use the statsd facilities available to us.

There are a few statsd servers that can be hit in the PHX datacenter, and we'd like to send data there.

They are located in the ganglia cluster.

Production should be allowed, so should staging, and hopefully dev.
The pancake production hosts are in PHX1 in VLAN 118:

pancake-elasticsearch1.labs.phx1.mozilla.com. 300 IN A 10.8.110.21
pancake-memcache1.labs.phx1.mozilla.com. 300 IN A 10.8.110.23
pancake-neo4j1.labs.phx1.mozilla.com. 300 IN A 10.8.110.22
pancake-userapi1.labs.phx1.mozilla.com. 300 IN A 10.8.110.20
pancake-web1.labs.phx1.mozilla.com. 300 IN A 10.8.110.16
pancake-web2.labs.phx1.mozilla.com. 300 IN A 10.8.110.17
pancake-web3.labs.phx1.mozilla.com. 300 IN A 10.8.110.18
pancake-web4.labs.phx1.mozilla.com. 300 IN A 10.8.110.19
Assignee: gozer → server-ops
Component: Dashboard → Server Operations
Product: Pancake → mozilla.org
QA Contact: dashboard → phong
Target Milestone: M3 → ---
Version: unspecified → other
(Assignee)

Comment 2

6 years ago
Would the stats be coming from web1-4? Are you using pystatsd as your client?
(Reporter)

Comment 3

6 years ago
pystatsd will be used, if not, something like it, with namespacing.

the stats will come from web1-4, pancake-user

the staging hosts should be added too, and hopefully our development instance on rackspace infrastructure as well.
Blocks: 687562
(Reporter)

Updated

6 years ago
Duplicate of this bug: 745777
(Assignee)

Comment 5

6 years ago
Ok, I'll need the DNS hostname and IPs of any servers you want to be able to connect, as I'll need to open bugs with NetOps to get flows setup.

I'm not sure how it would work with your servers on Rackspace, since statsd traffic is UDP and unencrypted.

I'll open a bug for the servers in comment 1 this week and we can confirm your statsd client works there, then tackle the other servers.
(Reporter)

Comment 6

6 years ago
i meant to say web1-4, pancake-userapi1 and some more host that :gozer can comment on that are in our staging environment.

Let's take the rackspace host off the table for now then. It is a host used only for development.
(Reporter)

Comment 7

6 years ago
Can you please also add these hosts?

pancake-web-stage1.vm1.labs.sjc1.mozilla.com
pancake-db-stage1.vm1.labs.sjc1.mozilla.com

Updated

6 years ago
Assignee: server-ops → bburton
(Assignee)

Updated

6 years ago
Summary: Please allow environments to send data to the statsd service in phx → [pancake] Allow environments to send data to the statsd service in phx
(Assignee)

Comment 8

6 years ago
So, for clarify, we'll be using the following as the source initially

pancake-userapi1.labs.phx1.mozilla.com. 300 IN A 10.8.110.20
pancake-web1.labs.phx1.mozilla.com. 300 IN A 10.8.110.16
pancake-web2.labs.phx1.mozilla.com. 300 IN A 10.8.110.17
pancake-web3.labs.phx1.mozilla.com. 300 IN A 10.8.110.18
pancake-web4.labs.phx1.mozilla.com. 300 IN A 10.8.110.19

For the following, we'll need their name/IPs of where they will be post moving out of SJC before we can get flows setup, so please let us know on that

pancake-web-stage1.vm1.labs.sjc1.mozilla.com
pancake-db-stage1.vm1.labs.sjc1.mozilla.com

Thanks

Updated

6 years ago
Depends on: 748849
(Assignee)

Comment 9

6 years ago
Sorry for the lack of updates, the flows were setup in 748849

Our Django sites that are using this setup use config options like the following

STATSD_HOST = '10.8.74.135'
STATSD_PORT = 8125
STATSD_PREFIX = 'flicks-prod'

Once you've configured your app, give it 30 minutes and a few requests and check https://graphite-phx.mozilla.org/
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.