Last Comment Bug 745395 - Replying to attached emails doesn't show the original message
: Replying to attached emails doesn't show the original message
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: 12 Branch
: All All
: -- major (vote)
: Thunderbird 14.0
Assigned To: Magnus Melin
:
:
Mentors:
Depends on:
Blocks: 389650
  Show dependency treegraph
 
Reported: 2012-04-13 18:51 PDT by Jim Porter (:squib)
Modified: 2012-04-17 22:12 PDT (History)
4 users (show)
mkmelin+mozilla: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
fixed


Attachments
proposed fix (2.13 KB, patch)
2012-04-16 13:08 PDT, Magnus Melin
mozilla: review+
Details | Diff | Splinter Review
proposed fix with test (7.29 KB, patch)
2012-04-17 11:19 PDT, Magnus Melin
mozilla: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Jim Porter (:squib) 2012-04-13 18:51:09 PDT
Works: 12/30/2011, broken: 12/31/2011.

If you open an attached message and try to reply to it, it shows the prelude "On x/y/z, Bob said", but doesn't actually quote the original message. Not sure what happened here...
Comment 1 Jim Porter (:squib) 2012-04-13 18:53:46 PDT
Bug 389650 is probably related...
Comment 2 Magnus Melin 2012-04-15 12:08:44 PDT
Hm, i think i spot the error.
Comment 3 :aceman 2012-04-16 01:41:16 PDT
May be related to bug 743739 (for TB 11)? There are 2 issues there, but "no quoted text" seems to be one of them.
Comment 4 Magnus Melin 2012-04-16 01:43:54 PDT
No this is from bug 389650... i misread one char there.
Comment 5 Magnus Melin 2012-04-16 13:08:16 PDT
Created attachment 615436 [details] [diff] [review]
proposed fix

One if-clause was using &... and the other ?...

This fixes it and makes it irrelevant where in the uri the param happens to be - still need to make a test for it.
Comment 6 Jim Porter (:squib) 2012-04-16 17:24:11 PDT
I tested this out and it fixes the error for me.
Comment 7 Mark Banner (:standard8, limited time in Dec) 2012-04-17 07:24:38 PDT
Comment on attachment 615436 [details] [diff] [review]
proposed fix

David, can you take a look at this? If we want it for 12 (which is where bug 389650 landed), then we'll need to land it asap.
Comment 8 David :Bienvenu 2012-04-17 09:53:55 PDT
Comment on attachment 615436 [details] [diff] [review]
proposed fix

would be good to have a mozmill test for this.
Comment 9 Magnus Melin 2012-04-17 11:19:28 PDT
Created attachment 615801 [details] [diff] [review]
proposed fix with test

With test - i won't be able to check in until tomorrow at the earliest, so if someone wants to do that...
Comment 10 David :Bienvenu 2012-04-17 11:46:01 PDT
Comment on attachment 615801 [details] [diff] [review]
proposed fix with test

thx so much, Magnus! I'll land this today, as soon as I verify that the test passes w/ the patch. I've verified that it fails w/o it.
Comment 11 David :Bienvenu 2012-04-17 12:29:45 PDT
fixed on trunk, thx, Magnus
Comment 12 David :Bienvenu 2012-04-17 12:30:50 PDT
Comment on attachment 615801 [details] [diff] [review]
proposed fix with test

reply, forward inline of .eml attachments won't work w/o this patch.
Comment 13 Mark Banner (:standard8, limited time in Dec) 2012-04-17 14:15:48 PDT
Comment on attachment 615801 [details] [diff] [review]
proposed fix with test

a=Standard8 to fix the regression.
Comment 14 Mark Banner (:standard8, limited time in Dec) 2012-04-17 14:23:49 PDT
(In reply to David :Bienvenu from comment #11)
> fixed on trunk, thx, Magnus

Trunk changeset: http://hg.mozilla.org/comm-central/rev/c89cbdbd4d64
Comment 15 Mark Banner (:standard8, limited time in Dec) 2012-04-17 14:34:50 PDT
Checked into branches:

http://hg.mozilla.org/releases/comm-aurora/rev/545a5c12ef35
http://hg.mozilla.org/releases/comm-beta/rev/d464d18772e8

Note You need to log in before you can comment on or make changes to this bug.