Folders appear collapsed in Folder Pane when Launch with Mail & News as default application

RESOLVED DUPLICATE of bug 748899

Status

SeaMonkey
MailNews: General
RESOLVED DUPLICATE of bug 748899
6 years ago
3 years ago

People

(Reporter: wondra, Unassigned)

Tracking

SeaMonkey 2.9 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20120413 Firefox/12.0 SeaMonkey/2.9
Build ID: 20120413213102

Steps to reproduce:

If simultaneously with Seamonkey the email program get startet, the sub-folders are not displayed in the left window.


Actual results:

the sub-folders are not displayed in the left window.Only after closing the mail program and re-opened, all sub-folders are visible.


Expected results:

If simultaneously with Seamonkey the email program get startet, in the left window in all e-mail accounts should be visible all the subfolders.

Comment 1

6 years ago
Can you try in SeaMonkey safe-mode? Help->Restart with Addons Disabled.
(Reporter)

Comment 2

6 years ago
(In reply to Philip Chee from comment #1)
> Can you try in SeaMonkey safe-mode? Help->Restart with Addons Disabled.

The same fault as before
(Reporter)

Comment 3

6 years ago
(In reply to Philip Chee from comment #1)
> Can you try in SeaMonkey safe-mode? Help->Restart with Addons Disabled.

By the way: The same behaviour at 3 different computers (windows 7) .

Updated

3 years ago
Component: General → MailNews: General

Comment 4

3 years ago
NOT reproducible as a general problem with  SeaMonkey 2.39a1 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0 from official download area)  Gecko/20100101  Firefox/42.0 (Classic Theme) on German WIN7 64bit:

0. I created a batch with
   CD C:<seamonkey program folder>
   seamonkey.exe -mail
1. I launched batch by double click
   » SeaMonkey opens with “Mail” as active application,
     Accounts and folders expanded as I saw it when I closed SM last time
     in the Folder Pane (that one what's visibility is toggled with <f9>)
3. All the same when I launch SM without batch, but with Menu 'Edit →
   Preferences → Appearance 
   → When SeaMonkey Starts up open with Mail & Newsgroups'

But SOMETIMES reproducible with SM. For Example, I saw the problem as visible in screenshot with same version after additional tests:

10. Select Menu 'Edit →
   Preferences → Appearance ', create a Test profile with at least 1 
   email-account if no such one does exist
   → When SeaMonkey Starts up open with Mail & Newsgroups'
11. Exit  → Launch SM
12. Menu 'Help → Restart with Add-ons disabled'
    » Launches with add-ons disabled
13. Menu 'Tools → Switch Profile  → Test account'
   » Test account appears  (I have “Clear private data when leave” 
     enabled for this account
14. Menu 'Help → Restart with Add-ons disabled'
    » Launches with add-ons disabled
15. Menu 'Tools → Switch Profile  → Normal account'
    » Mail & News appears with most accounts collapsed (only main folder
      expanded

Additional info:
a) often problem already appears in step 12, but not 100% reliable
b) effect in step 15 in 3 tests 100% reliable.
c) problem does exist for all tested account types IMAP, POP3, FEEDS, NEWS
d) Might be related to or DUP of “Bug 748899 - When launching only the
   mail component, POP3 accounts in the folder tree are collapsed.
e) Might be related to or DUP of “Bug 482869 - Remember collapsed/expanded 
   state of subfolders after collapse parent”
   Expanded/collapsed state is not preserved across restarts”
f) possibly other DUPs  in 
   <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=runnamed&namedcmd=DUPs745511>
g) This one probably also affects TB and so is a “MailNews core” problem

@reporter:
h) Still a problem for you?
   if yes, please contribute information:

i) did I describe your problem?
k) how exactly do you launch SeaMonkey?
l) Really only sub folders (inbox\subfolder and similar) or all folders
   affected, what would mean you only see account names?
   A screenshot would be fine 
m) Please tell more details concerning your accounts: POP3, IMAP? FEEDS? NEWS?
n) Other preferences what might be affected
o) was that a problem for you also in older versions?
Flags: needinfo?(wondra)
Summary: Problem with sub-folders in seamonkey mail → Folders appear collapsed in Folder Pane when Launch with Mail & News as default application

Comment 5

3 years ago
Created attachment 8632524 [details]
screenshot.png

Screenshot for comment above
(Reporter)

Comment 6

3 years ago
Sorry, this problem was reported in the year 2012. I don't use SeaMonkey any more.
Flags: needinfo?(wondra)

Comment 7

3 years ago
@reporter:
You don't use Thunderbird, too?
See Also: → bug 748899, bug 482869
(Reporter)

Comment 8

3 years ago
I use Thunderbird - up to now with no problems.

Comment 9

3 years ago
p) After some more research I doubt that the effect I see has the same roots as 
   reporter's problem. The problem what appeared with 2.9 disappeared with 2.11,
   see Bug 748899
   And I do not reproduce the Problem with  EN-US SeaMonkey 2.26  (Portable) 
   Gecko/20100101 Firefox/29.0 Build 20140428215944 ( Classic Theme) on 
   German WIN7 64bit 
q) I doubt that Bug 482869 has to do with this one
r) Due to version of appearance I mark this one as DUP of Bug 748899
   For observation with current Versions I will open a new Bug Report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
See Also: bug 482869
Duplicate of bug: 748899
You need to log in before you can comment on or make changes to this bug.