Exiting DOM fullscreen exits Lion fullscreen too

RESOLVED DUPLICATE of bug 947854

Status

()

RESOLVED DUPLICATE of bug 947854
7 years ago
4 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
STR:
1) Enable HTML5 on youtube
2) Load an HTML5-enabled youtube video
3) Click the Lion fullscreen button at the top right corner of the window
4) Click the full screen button in the youtube UI
5) Press esc

Actual result:
Pressing esc exits both DOM fullscreen and Lion fullscreen

Expected result:
Expected pressing esc to exit only DOM fullscreen but not Lion fullscreen.
(Reporter)

Updated

7 years ago
Summary: Exiting DOM fullscreen exit Lion fullscreen too → Exiting DOM fullscreen exits Lion fullscreen too
I guess that's reasonable behaviour on Lion...
(Reporter)

Comment 2

7 years ago
(In reply to Chris Pearce (:cpearce) from comment #1)
> I guess that's reasonable behaviour on Lion...

"That" referring to "actual result" or "expected result"? Basically, I expect exiting DOM fullscreen to take me back to whatever the prior window state was.
Your expected result. I agree with you; exiting DOM fullscreen should restore you to the prior state.
I guess the natural progression of this argument is that if you're in browser fullscreen mode on other platforms, and you enter DOM fullscreen, exiting DOM fullscreen should return you to browser fullscreen mode.

I'm not sure about having ESC rollback to browser fullscreen mode though; ESC is supposed to totally exit from fullscreen, so the user can be sure they're back in normal mode and sure that they aren't being spoofed. Not sure if we should do that or not, have to think on it.

(Note there are two separate cases here: calling document.mozCancelFullScreen() to revert to the prior state, and pressing ESC to bail back to normal mode.)
(Reporter)

Comment 5

7 years ago
(In reply to Chris Pearce (:cpearce) from comment #4)
> I'm not sure about having ESC rollback to browser fullscreen mode though;
> ESC is supposed to totally exit from fullscreen, so the user can be sure
> they're back in normal mode and sure that they aren't being spoofed.

Lion fullscreen paints the tab bar and the location bar, so the site doesn't get to spoof the whole screen when Firefox is in Lion fullscreen.

The way I, as a user, see Lion fullscreen is that it's a way to opt out of legacy windowing to a more single-app-centric experience. I enter that experience by clicking a button in the top right of a window. I leave that experience by clicking a button at the top right of the menubar after I've made the menubar appear by hovering the top of the screen. I know how to leave Lion fullscreen, because it's a system-wide consistent thing.

When I take a video on a site to fullscreen with site-provided controls, I want the video to cover really the entire screen and temporarily get rid of the tab bar and the location bar. I want esc to take me out of that state so that I don't need to trust the site to provide me with a way out that I need to discover. To me, pressing esc is a browser-level thing. I don't want to take an OS-level action at the same time. And the OS-level thing isn't spoofing-relevant, because the toolbars are there.
duping to a newer bug, which was already triaged and put in firefox backlog.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947854
You need to log in before you can comment on or make changes to this bug.