After 2nd iteration Gtk-WARNING **: cannot open display: _WSA210:

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Bob Smith, Assigned: asa)

Tracking

Trunk
DEC
OpenVMS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
CRDEV2_PROD_DBA> @sys$common:[mozilla]mozilla
Starting mozilla-bin...
Registering plugin 0 for: "*","All types",".*"
Registering plugin 0 for: "*","All types",".*"
Runtime mismatch, so leaking context!
CRDEV2_PROD_DBA> @sys$common:[mozilla]mozilla
Starting mozilla-bin...

Gtk-WARNING **: cannot open display: _WSA210:
%CXXL-F-TERMINATE, terminate() or unexpected() called
%TRACE-F-TRACEBACK, symbolic stack dump follows
  image    module    routine             line      rel PC           abs PC

The above describes one successful iteration the second shortly after fails on 
a second.  If I create a new excursion session all is working again. I had set 
the MAXBOBMEM to 3200 from 1600.  Otherwise I was getting the error everytime at 
1600.  So I then upp'd it to 4800 and it still doesn't work.  There are 2 other 
parameters MAXBOBS0S1 and MAXBOBS2, could these parameter contribute to the 
problem.  Below are my sysgen settings for these fields.

SYSGEN>  SHO MAXBOB
Parameter Name           Current    Default     Min.      Max.     Unit  Dynamic
--------------           -------    -------    -------   -------   ----  -------
MAXBOBMEM                    3200       1600         0         -1 Pagelets   D
 internal value               200        100         0         -1 Pages      D
MAXBOBS0S1                   1600       1600         0         -1 Pagelets   D
 internal value               100        100         0         -1 Pages      D
MAXBOBS2                     1600       1600         0         -1 Pagelets   D
 internal value               100        100         0         -1 Pages      D
ccing Colin

Comment 2

17 years ago
The MAXBOB sysgen parameters are used to configure the amount of memory used by 
buffer objects (a very OpenVMS specific concept). Since both Mozilla and GTK are 
cross-platform applications neither use buffer objects and therefore I don't 
think that there's anything broken in the Mozilla or GTK code. This is likely a 
configuration issue of some sort. 

Check that you have all the applicable ECO's installed on your system. In 
particular any DECwindows and DECwindows device driver ECO kits.

Your best bet is to contact Compaq's support staff and get them to help you. 
This really sounds like a VMS/DECwindows configuration issue, and that is not an 
area in which I could even remotely call myself an expert.

If you come to a dead end, or if you really think its a Mozilla problem, then
reopen this bug report and I'll work with you the best I can. But its not going 
to be the fastest way to solve this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.