Closed Bug 745665 Opened 10 years ago Closed 10 years ago

Category missing from app detail page

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED
2012-05-10

People

(Reporter: cvan, Assigned: cvan)

References

()

Details

Attachments

(1 file)

Steps to reproduce:
1) Submit an app with two categories.
2) Notice only one categories is listed on the detail page (in the breadcrumb).

Management URL:
https://marketplace-dev.allizom.org/en-US/developers/app/seevans-underworld-adventur/edit

Detail URL:
https://marketplace-dev.allizom.org/en-US/app/seevans-underworld-adventur/
I thought we brought this up a long time ago and decided to only let people put their apps in one category.  CCing Bryan and diane.
Priority: -- → P3
Assignee: nobody → cvan
Target Milestone: --- → 6.5.2
Priority: P3 → --
If a user filters by games and finds App A.  and then they filter by music and find App A, that is good for App A and for the user.

But honestly, I don't have a strong opinion here.
Target Milestone: 6.5.2 → 6.5.4
I don't understand comment 3.  If no one else chimes in limiting it to 1 category is fine.
Blocks: 752013
No longer blocks: 735054
Priority: -- → P3
Duplicate of this bug: 753088
The way I read comment 3 is that multiple categories help users find more relevant apps so we should allow multiple categories :)

Another way to look at this is bug 753088 where the user was depending on the breadcrumbs to trace a specific path. The user clicked on the Music category, viewed a music app, then used the breadcrumb to go back to Music. That problem is easy to solve: we can just make the breadcrumbs reflect the last category viewed (if there was one).
That's the easy case.  What do you show when I search for "adblock" and click on it from a search result?  Or my friend sends me a link to the detail page?
(In reply to Wil Clouser [:clouserw] from comment #7)
> That's the easy case.  What do you show when I search for "adblock" and
> click on it from a search result?  Or my friend sends me a link to the
> detail page?

is the current behavior a problem in those cases? :) I'd say no.
https://github.com/mozilla/zamboni/commit/ceef86f
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.