DB column 'query_type' missing in table 'namedqueries' after upgrade to 4.2

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: mrenelt, Unassigned)

Tracking

x86_64
Linux

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 615260 [details]
Output of checksetup.pl before upgrade

We tried to upgrade our bugzilla installation from 4.0.1 to 4.2 this weekend.
Followed the upgrade procedure on http://www.bugzilla.org/docs/4.2/en/html/upgrade.html
Sanity check was run before upgrade and checksetup.pl after it
Bugzilla returns the following error message after upgrade:

Template->process() failed twice.
First error: undef error - DBD::mysql::db selectall_arrayref failed: Unknown column 'query_type' in 'field list' [for Statement "SELECT id,userid,name,query,query_type FROM namedqueries WHERE id IN (?,?,?,?) ORDER BY name"] at /srv/www/bugzilla/Bugzilla/Object.pm line 276 Bugzilla::Object::_do_list_select('Bugzilla::Search::Saved', ' id IN (?,?,?,?) ', 'ARRAY(0xb9cf0614)', undef) called at /srv/www/bugzilla/Bugzilla/Object.pm line 253 [...]


Same problem was seen with an intermediate update to 4.0.5 and then to 4.2
The column 'query_type' is indeed missing from the table 'namedqueries'.

Software environment:

OpenSuSE 11.3
Apache/2.2.21
mod_perl 2.0.4
No addons are installed besides german and french templates

Is there any additional information I should add?

Comment 1

6 years ago
query_type no longer exists in 4.2. So the problem is not your DB, but the code you have for 4.2. Make sure you have no old customizations or extensions compatible with 4.0 only.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.