If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash opening an email attachment (from Word) [@ nsHtml5UTF16Buffer::hasMore() ]

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
--
critical
RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: zetka, Unassigned)

Tracking

(Blocks: 1 bug, {crash, testcase})

11 Branch
x86
Windows XP
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tbird crash] [seamonkey-2.13-affected], crash signature)

Attachments

(3 attachments)

3.42 MB, application/octet-stream
Details
3.45 MB, application/octet-stream
Details
3.35 MB, application/octet-stream
Details
(Reporter)

Description

6 years ago
Created attachment 615273 [details]
fefí285.eml

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20120312 Firefox/11.0 SeaMonkey/2.8
Build ID: 20120312220748

Steps to reproduce:

I have an email with Word attachment, filename fefí 285.doc , size 788kb. It is in Czech, the email is attached below for testing.


Actual results:

After double click on the attachment or right click and open on the attachment the Sea monkey crashes. In case of saving the attachment to disk the MS Word opens the file without problem. It happens not only on one but more docs.
It is interesting, that other similar attachment in Word it opens without problem.
I have allowed to send the crash report to Mozilla.


Expected results:

It should open the Word and open the attachment inside it.
(Reporter)

Updated

6 years ago
Severity: normal → major
Can you please provide the crash ID from about:crashes ?
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
(Reporter)

Comment 2

6 years ago
IDs are those:
bp-686b7268-161e-42ff-97bb-a06f12120416   16.4.201216:27
bp-fc866ff3-9c70-4c7d-b6f6-c12252120416   16.4.201210:37
bp-ccad1645-44b6-4383-88df-9f74b2120416   16.4.201210:37
bp-2032a761-dc92-4074-ae5d-b0bd02120416   16.4.201210:35
bp-964f1c3b-416f-4d0b-9710-3d3ab2120416   16.4.201210:35
bp-464e6a60-b0d6-4041-9b7a-d71992120416   16.4.201210:26

all of those are after the doc attachment opening crash.

Updated

6 years ago
Crash Signature: [@ nsHtml5UTF16Buffer::hasMore() ]
Component: MailNews: General → HTML: Parser
Product: SeaMonkey → Core
QA Contact: mail → parser
Summary: crash of Sea Monkey after trying to open an email doc attachment from Word → crash of Sea Monkey after trying to open an email doc attachment from Word [@ nsHtml5UTF16Buffer::hasMore() ]
Version: SeaMonkey 2.8 Branch → 11 Branch
Severity: major → critical
Keywords: crash
(Reporter)

Comment 3

6 years ago
Looking after a week. A little bit disapointed about zero activity when solving this CRITICAL crash problem.
Is there a way to reproduce by serving the HTML payload of the email over HTTP to Firefox?
(Reporter)

Comment 5

6 years ago
I am not fully understanding - this concerns SeaMonkey mail, I can imagine that similar problem could be in Thunderbird, but I do not understand the role of Firefox in this case.
The crash is in the HTML parser, so the question is if it's possible to provoke the crash by putting the HTML over HTTP instead of putting it over email.
(Reporter)

Comment 7

5 years ago
In case you need any support from me, let me know and exactly describe what to do to go further.
(Reporter)

Comment 8

5 years ago
The situation is still the same, crash when trying to load doc attachment from email. Does anybody viewed and solved this problem?
for whatever reason, this is only happening in Seamonkey. 
Does it happen if you have started Seamonkey in safe mode?
Flags: needinfo?(zetka)
seen also in newer versions llike 2.13.1 bp-c7210e2b-1df1-4b49-8bb6-b938e2121026
(Reporter)

Comment 11

5 years ago
Created attachment 676556 [details]
this attachment crashes
Flags: needinfo?(zetka)
(Reporter)

Comment 12

5 years ago
Created attachment 676557 [details]
here the attachment could be opened, NO CRASH
(Reporter)

Comment 13

5 years ago
After few updates the certain doc attachment opening  means crash, but I have seen the same on video attachments as well now.
(Reporter)

Comment 14

5 years ago
I can confirm, that the crash appears in the safe mode too.
I can't reproduce, but thunderbird also has examples bp-376f9e80-0ed1-4e15-9a07-cfa4c2121023

bp-8f4c519e-4d7f-4341-aea8-4830b2121030 is one of zetka's
0	xul.dll	nsHtml5UTF16Buffer::hasMore	parser/html/nsHtml5UTF16Buffer.cpp:84
1	xul.dll	nsHtml5StreamParser::ParseAvailableData	parser/html/nsHtml5StreamParser.cpp:1297
2	xul.dll	nsHtml5RequestStopper::Run	parser/html/nsHtml5StreamParser.cpp:1027
3	xul.dll	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:624 

mwu@79146 81bool
hsivonen@29805 82nsHtml5UTF16Buffer::hasMore()
hsivonen@29805 83{
hsivonen@29805 84 return start < end; 

3 seamonkey examples all mentioning pdf. all have reporter email addresses
bp-e55f47fd-50e6-423c-8faa-039172121016
bp-755a7919-626e-4f56-8e0b-8d8962121028
bp-894f6cdc-2cea-4406-91eb-7cba62120925
Status: UNCONFIRMED → NEW
Crash Signature: [@ nsHtml5UTF16Buffer::hasMore() ] → [@ nsHtml5UTF16Buffer::hasMore() ] [@ nsHtml5UTF16Buffer::hasMore ] [@
Ever confirmed: true
Whiteboard: [tbird crash]
Those 3 SeaMonkey crashes are respectively on 2.13.1 (Linux on AMD processor), 2.13.2 (Linux on Intel processor) and 2.12.1 (Mac OS X). The current "stable" branch is 2.13.2 since 27 October.
Whiteboard: [tbird crash] → [tbird crash] [seamonkey-2.13-affected]

Comment 17

5 years ago
Still crashes in SM Nightly under Win XP, 
http://crash-stats.mozilla.com/report/index/bp-c4384d5f-809a-4ae0-9ad3-d33222130304

In Thunderbird 17.0.3 under Linux the dialog box "Open with Application or Save and should this be done every time?" doesn't appear after trying to open this DOC attachment.

(In reply to Wayne Mery (:wsmwk) from comment #15)
> I can't reproduce, but thunderbird also has examples

Do you have a helper application set for DOC files?

What influence has the bad content-type header?
> Content-Type: cdf v2 document, corrupt: can't read sat;
> 	charset=utf8;
> 	name="=?iso-8859-2?Q?fef=ED=20285=2Edoc?="
This crash is now very rare, with serveral being startup. So I'm not even sure the current crashes are the same issue.

zetka, do you still see this problem?
Flags: needinfo?(zetka)
testcase in bug 1277038 crashes Thunderbird straight off
Flags: needinfo?(zetka)
Keywords: testcase
Summary: crash of Sea Monkey after trying to open an email doc attachment from Word [@ nsHtml5UTF16Buffer::hasMore() ] → crash opening an email attachment (from Word) [@ nsHtml5UTF16Buffer::hasMore() ]
Blocks: 1277038

Comment 20

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #19)
> testcase in bug 1277038 crashes Thunderbird straight off
Not for me, see bug 1277038 comment #1.

With the three attachments here (attachment 615273 [details], attachment 676556 [details], attachment 676557 [details]) I don't get any crash with TB 49 (Daily from today).
Thanks for testing.  I agree, testcases from this bug do not crash for me.
But for me, oddly, bug 1277038 testcase crashes builds 45.2b1, 48.0a1, and today's daily (new profile).
bp-1938b786-96f2-4d25-a03c-82df42160531
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.