If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reuse existing tab for same app launch in about:apps

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
Web Apps
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: aaronmt, Assigned: mfinkle)

Tracking

({regression})

Trunk
Firefox 14
ARM
Android
regression
Points:
---
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(firefox14 verified, blocking-fennec1.0 soft)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Currently when one launches the same application (as is currently running in a separate tab) in about:apps, a new tab is created.

STR:

i) https://apps.mozillalabs.com/appdir/ -- install any app
ii) about:apps, launch app (new tab is created)

Repeat ii., a new tab is created.

Shouldn't it reuse the existing tab?

--
Nightly (04/16)
Samsung Galaxy Nexus (Android 4.0.4)
I believe this was working when the first about:apps patch landed (reuse of the existing tab). Flagging as a regression.
Keywords: regression

Updated

6 years ago
See Also: → bug 745745
Implementation of this bug needs to be consistent with bug 745745.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 745745
Created attachment 615384 [details] [diff] [review]
patch

The problem was the WebappsUI.openURL code was using aOrigin as the "cookie" but the homescreen intent was using the launch URI. This patch makes the WebappsUI.openURL code use the excact same code as the homescreen intent. Both paths use the launch URI as the "cookie" to tag a tab.
Assignee: nobody → mark.finkle
Attachment #615384 - Flags: review?(fabrice)
Note for testing - Make sure this is tested by launching the same application twice both from about:apps and from a homescreen shortcut.
Attachment #615384 - Flags: review?(fabrice) → review+
soft blocking nom. fixes launch behavior for webapps.
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → soft
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b890b87bac9
https://hg.mozilla.org/mozilla-central/rev/7b890b87bac9
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
(Reporter)

Comment 9

6 years ago
Verified Fixed

Nightly (04/29)
Samsung Galaxy Note (Android 2.3), Samsung Galaxy Nexus (Android 4.0.4)
Status: RESOLVED → VERIFIED
status-firefox14: --- → verified

Updated

6 years ago
Flags: in-moztrap?

Updated

5 years ago
Flags: in-moztrap? → in-moztrap?(aaron.train)
(Reporter)

Comment 10

5 years ago
MozTrap: https://moztrap.mozilla.org/manage/case/258/
Flags: in-moztrap?(aaron.train) → in-moztrap+
You need to log in before you can comment on or make changes to this bug.