Uncaught TypeError: Cannot set property 'onclose' of undefined

RESOLVED WORKSFORME

Status

Mozilla Labs
Identity
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: ringe, Unassigned)

Tracking

Details

(Whiteboard: [qa+])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.162 Safari/535.19

Steps to reproduce:

I've implemented BrowserID as shown at https://developer.mozilla.org/en/BrowserID/Quick_Setup in a Ruby gem devise-browserid, as described here: https://github.com/ringe/devise-browserid with the client side javascript shown here: https://github.com/ringe/devise-browserid/blob/master/vendor/assets/javascripts/browserid.js


Actual results:

When I click on the BrowserID button I get:
Uncaught TypeError: Cannot set property 'onclose' of undefined
navigator.id.getinclude.js:1
browserIdLoginbrowserid.js:22
(anonymous function)sign_in:44
onclick


Expected results:

A new window should have opened showing the BrowserID login.
See https://github.com/mozilla/browserid/issues/1442
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [qa+]
(Reporter)

Comment 2

6 years ago
Fix in https://github.com/mozilla/browserid/issues/1442 works for me.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.