Submitting or editing a demo to demo studio leads to 404 page not found

VERIFIED FIXED

Status

developer.mozilla.org
Demo Studio / Dev Derby
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: pmorris, Assigned: ubernostrum)

Tracking

Details

(Whiteboard: u=user c=bug s=2012-05-08 p=1 t=2012-05-22)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20120414 Firefox/13.0a2
Build ID: 20120414042009

Steps to reproduce:

I uploaded a demo, and later edited it.  Both times I clicked the "submit" button after making changes / entering info.


Actual results:

A new page loaded:
https://developer.mozilla.org/en-US/demos/detail/audiovisualizer-for-alternative-music-notation-systems

...but it showed a 404, page not found error.  (Maybe it is an error in the url?)


Expected results:

A confirmation screen that the demo submission or edits were successful.
(Reporter)

Comment 1

6 years ago
Looks like it's an issue where the title of the demo is too long, and so the actual working url is this, with a truncated title:

https://developer.mozilla.org/en-US/demos/detail/audiovisualizer-for-alternative-music-notation-sys

Whereas submitting or editing the demo sends you to this URL with the full title:

https://developer.mozilla.org/en-US/demos/detail/audiovisualizer-for-alternative-music-notation-systems
Good catch, we'll pull it into our next sprint.
Whiteboard: u=user c=bug s=2012-05-08 p=
Whiteboard: u=user c=bug s=2012-05-08 p= → u=user c=bug s=2012-05-08 p=1
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

6 years ago
Assignee: nobody → jbennett

Comment 3

6 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/618649427a7b4a01c83857cecfb35b1c0a5c8fd7
Fix bug 745902: Truncate demo slug when saving at the Python level, so that we don't try to construct URLs from a too-long slug.

https://github.com/mozilla/kuma/commit/220bb67df112fa0b8d366cc1cb044b7b66b82cd5
Merge pull request #204 from ubernostrum/demo-urls-745902

Bug 745902

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: u=user c=bug s=2012-05-08 p=1 → u=user c=bug s=2012-05-08 p=1 t=2012-05-22
Status: RESOLVED → VERIFIED
Component: Demos → Demo Studio / Dev Derby
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.