Closed Bug 745987 Opened 8 years ago Closed 8 years ago

wiki.mozilla.org Maintenance - April 19th 10PM - 1AM Pacific

Categories

(Infrastructure & Operations Graveyard :: WebOps: Other, task)

x86
macOS
task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bburton, Assigned: bburton)

Details

Attachments

(1 file)

Tracking progress on and any issues after wiki.mozilla.org Maintenance - April 19th 9PM - Midnight PST
Summary: wiki.mozilla.org Maintenance - April 19th 9PM - Midnight PST → wiki.mozilla.org Maintenance - April 19th 10PM - 1AM Pacific
test edit on phx1. everything looks good :)
I see the following text on the top of
https://wiki.mozilla.org/Program_Management/Programs/Apps/Site_Compatibility

Also, all chart images from the mediawiki-bugzilla extension are broken

Notice: Trying to get property of non-object in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/BugzillaOutput.class.php on line 69 Notice: Trying to get property of non-object in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/BugzillaOutput.class.php on line 69 Warning: imagepng(): Unable to open '/75385932adf5e016c4c767b0d7744e53.png' for writing: Permission denied in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/pchart/class/pImage.class.php on line 151 Warning: imagepng(): Unable to open '/6fa5a57c61e9cb790a896e626ea2e30b.png' for writing: Permission denied in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/pchart/class/pImage.class.php on line 151 Warning: imagepng(): Unable to open '/266c20ca7c2a6967ddfc368baaa960b2.png' for writing: Permission denied in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/pchart/class/pImage.class.php on line 151 Warning: imagepng(): Unable to open '/4043c1dfcca86c8965c183a8a317da3c.png' for writing: Permission denied in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/pchart/class/pImage.class.php on line 151
The search link in the wikimo header is partially hidden behind the search bar.
I am looking into the issue in c2, but c3 and c4 appear to be skin related bugs and will be addressed later.

Thanks
Status: NEW → ASSIGNED
Another skin-related bug: The "Mozilla Wiki" logo at the top left is missing, and the dino head in the top left corner is half missing.
Yes, some settings differences in PHP (more secure defaults on RHEL6) are causing issues with our skin :(

We're sorting it out now
We just fixed a couple skin bugs due to a change in the PHP "short tags" setting... old cluster allowed them, new cluster doesn't. 3 lines changed. No more broken images that I see. The issue in comment 2 still exists.
I still see error text at the top of the page that I listed in comment 2, but it is different (shorter) text now. All of the chart images now display. 

I now see the image that was missing as per comment 3, however the footer does not look correct.
Yes, I'm still working on getting the Bugzilla extension sorted out
:lmandel I think this may be a bug with some pages using Charts and the extension, with PHP 5.3

I've found a couple other pages with only one chart that don't show the error.

Do you know of other pages with multiple charts on them that I could check? Unfortunately there's not any easy way to search for all pages that use the Bugzilla extension charting.
Here are two other pages with multiple charts:
https://wiki.mozilla.org/Performance/Snappy/
https://wiki.mozilla.org/Performance/Snappy/Dashboard

Note that I don't see an error on either page. The error I see on the site compatibility page is now:

Notice: Trying to get property of non-object in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/BugzillaOutput.class.php on line 69 Notice: Trying to get property of non-object in /data/www/wiki.mozilla.org/wiki/extensions/Bugzilla/BugzillaOutput.class.php on line 69
One of the bigger changes with this maintenance is that the old cluster was PHP 5.2 and the new one is PHP 5.3. Given the wording of that error, I'm guessing this might be related. Perhaps something about that code doesn't work in 5.3?

For a start:
http://www.php.net/manual/en/migration53.incompatible.php

Another possibility is that this code relies on some particular PHP setting to be a particular way, and it happened to be that way on the old cluster but is different on the new one (like the short open tags from comment 8). What this might be, I can't say for sure. Perhaps someone familiar with the code could point out what settings, if any, would be potential culprits...
I've opened https://github.com/LegNeato/mediawiki-bugzilla/issues/10 work with the extension devs to track this down
i got a certificate error on todays morning
That sounds like you're using something that doesn't have SNI support or isn't picking up the Intermediate certificate.

Can you provide a screenshot of the error and attach it to this bug?

Thanks!
(In reply to Brandon Burton [:solarce] from comment #16)
> That sounds like you're using something that doesn't have SNI support or
> isn't picking up the Intermediate certificate.
> 
> Can you provide a screenshot of the error and attach it to this bug?
> 
> Thanks!

i am using Firefox 12b6 with Win7x86, i added a security exception so i am not able to reproduce this issue anymore!
Attached image certificate error!
(In reply to Brandon Burton [:solarce] from comment #16)
> That sounds like you're using something that doesn't have SNI support or
> isn't picking up the Intermediate certificate.
> 
> Can you provide a screenshot of the error and attach it to this bug?
> 
> Thanks!

so i removed cert8.db and try to reproduce the issue and here is the screenshot!
A person in IRC reported: "I have a little problem with uploading a pic to mozilla wiki. Does anyone knows if it's a known issue...?"
As :wenzel has mentioned, I tried uploading an image.  The image *appears* to have been uploaded, but viewing the image displays an error.

https://wiki.mozilla.org/File:Persona_user_flow_dialog.png is the uploaded image. When opening this URL, I see the following error:

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 15135309 bytes) in /data/www/wiki.mozilla.org/wiki/includes/media/Bitmap.php on line 362
I see this error when I try uploading a PDF file:
"File extension does not match MIME type."
(In reply to Frank Lee from comment #21)
> I see this error when I try uploading a PDF file:
> "File extension does not match MIME type."

This is an UI issue, it's not a good error message, but the problem is that what you've entered in the filename field doesn't have the same extension as the file you're uploading, they must match.

See https://skitch.com/solarce/8t58h/upload-file-mozillawiki for an example of how the upload form should be filled out.

I'm looking into having our skin updated to modify the text of the upload page.
(In reply to Swarnava Sengupta (:Swarnava) from comment #18)
> Created attachment 617234 [details]
> certificate error!
> 
> so i removed cert8.db and try to reproduce the issue and here is the
> screenshot!

Can you toggle open the "Technical Details" section on that and then screenshot it again?
(In reply to Shane Tomlinson [:stomlinson] from comment #20)
> As :wenzel has mentioned, I tried uploading an image.  The image *appears*
> to have been uploaded, but viewing the image displays an error.
> 
> https://wiki.mozilla.org/File:Persona_user_flow_dialog.png is the uploaded
> image. When opening this URL, I see the following error:
> 
> Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to
> allocate 15135309 bytes) in
> /data/www/wiki.mozilla.org/wiki/includes/media/Bitmap.php on line 362

I'm able to view your upload just fine, please let me know if you're still seeing this issue.

Thanks!
(In reply to Dave Miller [:justdave] from comment #23)
> (In reply to Swarnava Sengupta (:Swarnava) from comment #18)
> > Created attachment 617234 [details]
> > certificate error!
> > 
> > so i removed cert8.db and try to reproduce the issue and here is the
> > screenshot!
> 
> Can you toggle open the "Technical Details" section on that and then
> screenshot it again?

Additionally, 12.0 stable is due out soon, can you upgrade once the release hits and see if the issue remains?

Thanks!
(In reply to Brandon Burton [:solarce] from comment #22)
> (In reply to Frank Lee from comment #21)
> > I see this error when I try uploading a PDF file:
> > "File extension does not match MIME type."
> 
> This is an UI issue, it's not a good error message, but the problem is that
> what you've entered in the filename field doesn't have the same extension as
> the file you're uploading, they must match.
> 
> See https://skitch.com/solarce/8t58h/upload-file-mozillawiki for an example
> of how the upload form should be filled out.
> 
> I'm looking into having our skin updated to modify the text of the upload
> page.

that was it, thanks! .f.
For comment #2 I would just turn off notices (E_ALL & ~E_NOTICE & ~E_DEPRECATED) and think about turning off html_errors.

I'll still look into the code in https://github.com/LegNeato/mediawiki-bugzilla/issues/10
(In reply to Brandon Burton [:solarce] from comment #25)
> (In reply to Dave Miller [:justdave] from comment #23)
> > (In reply to Swarnava Sengupta (:Swarnava) from comment #18)
> > > Created attachment 617234 [details]
> > > certificate error!
> > > 
> > > so i removed cert8.db and try to reproduce the issue and here is the
> > > screenshot!
> > 
> > Can you toggle open the "Technical Details" section on that and then
> > screenshot it again?
> 
> Additionally, 12.0 stable is due out soon, can you upgrade once the release
> hits and see if the issue remains?
> 
> Thanks!

(In reply to Dave Miller [:justdave] from comment #23)
> (In reply to Swarnava Sengupta (:Swarnava) from comment #18)
> > Created attachment 617234 [details]
> > certificate error!
> > 
> > so i removed cert8.db and try to reproduce the issue and here is the
> > screenshot!
> 
> Can you toggle open the "Technical Details" section on that and then
> screenshot it again?

cant reproduce this issue anymore.. i will report if i seen it again!
I've got an issue with the Mozilla Wiki. I'm a new user to the Wiki (Robkoch86) and I'm not able to confirm my e-mail address. I've tried two different addresses - but I did not receive any e-mail.
Can't edit my even or profile on the wiki. Don't know if it's an issue with the maintenance or something else.
meant event, not even. Sorry for the typo :-)
the problem seems to have gone, whatever it was. sorry for disturbing.
(In reply to Brandon Burton [:solarce] from comment #25)
> (In reply to Dave Miller [:justdave] from comment #23)
> > (In reply to Swarnava Sengupta (:Swarnava) from comment #18)
> > > Created attachment 617234 [details]
> > > certificate error!
> > > 
> > > so i removed cert8.db and try to reproduce the issue and here is the
> > > screenshot!
> > 
> > Can you toggle open the "Technical Details" section on that and then
> > screenshot it again?
> 
> Additionally, 12.0 stable is due out soon, can you upgrade once the release
> hits and see if the issue remains?
> 
> Thanks!

I've got the same certificate error. Technical details says:
wiki.mozilla.org uses an invalid security certificate.

The certificate is only valid for tbpl.mozilla.org

(Error code: ssl_error_bad_cert_domain)
I tried to upload a jpeg file created with GIMP, and I got the error "File extension does not match MIME type." The file name was "FTDI-USB-Adapter.jpg"
(In reply to Dave Hylands [:dhylands] from comment #34)
> I tried to upload a jpeg file created with GIMP, and I got the error "File
> extension does not match MIME type." The file name was "FTDI-USB-Adapter.jpg"

Doh - I think I filled something invalid in the destination filename and that's why it complained.
wiki.mozilla.org has been given it's own IP, so users who don't have SNI support will no longer see certificate issues.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.