tab switching regression when switching to a planet mozilla tab

RESOLVED DUPLICATE of bug 746055

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 746055
6 years ago
6 years ago

People

(Reporter: timbugzilla, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120416 Firefox/14.0a1
Build ID: 20120416030739

Steps to reproduce:

Navigate to http://planet.mozilla.org/ and allow the page to load and render. Switch to another tab then switch back to the planet mozilla tab. 


Actual results:

There is an ~ 1s lag before the planet mozilla tab is displayed. This behaviour started with the 20120416 build. This has been reproduced in safe-mode. 

about:support info:



  Application Basics

        Name
        Firefox

        Version
        14.0a1

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120416 Firefox/14.0a1

        Profile Folder

          Show Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        2.0.4b.3443
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        British English Dictionary
        1.19.1
        true
        en-GB@dictionaries.addons.mozilla.org

        Close Tab By Double Click
        1.14
        true
        close@doubleclick

        DictionarySearch
        10.0.0
        true
        {a0faa0a4-f1a7-4098-9a74-21efc3a92372}

        Element Hiding Helper for Adblock Plus
        1.2.3a.416
        true
        elemhidehelper@adblockplus.org

        Nightly Tester Tools
        3.2.2
        true
        {8620c15f-30dc-4dba-a131-7c5d20cf4a29}

        NoScript
        2.3.7
        true
        {73a6fe31-595d-460b-a920-fcc0f8843232}

        PDF Viewer
        0.2.414
        false
        uriloader@pdf.js

        Readability
        2.2
        false
        readability@readability.com

        Zotero
        3.0.3
        false
        zotero@chnm.gmu.edu

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.smart_size.enabled
        false

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        1048576

        browser.places.smartBookmarksVersion
        4

        browser.startup.homepage
        http://www.google.co.uk/

        browser.startup.homepage_override.buildID
        20120416030739

        browser.startup.homepage_override.mstone
        14.0a1

        dom.disable_window_move_resize
        true

        extensions.checkCompatibility.6.0b
        false

        extensions.checkCompatibility.6.0p
        false

        extensions.checkCompatibility.6.0pre
        false

        extensions.lastAppVersion
        14.0a1

        gfx.content.azure.enabled
        false

        gfx.direct3d.prefer_10_1
        true

        gfx.font_rendering.cleartype_params.force_gdi_classic_for_families
        Arial,Courier New,Tahoma,Trebuchet MS,Verdana,Segoe UI

        gfx.font_rendering.cleartype_params.force_gdi_classic_max_size
        20

        mousewheel.acceleration.factor
        4

        mousewheel.acceleration.start
        1

        network.cookie.cookieBehavior
        1

        network.cookie.prefsMigrated
        true

        network.prefetch-next
        false

        places.database.lastMaintenance
        1334118023

        places.history.expiration.transient_current_max_pages
        104858

        places.history.expiration.transient_optimal_database_size
        167772160

        plugin.disable_full_page_plugin_for_types
        application/pdf,video/x-mpeg,video/mpeg

        print.print_printer
        Brother HL-2030 series

        print.printer_Adobe_PDF.print_bgcolor
        false

        print.printer_Adobe_PDF.print_bgimages
        false

        print.printer_Adobe_PDF.print_command

        print.printer_Adobe_PDF.print_downloadfonts
        false

        print.printer_Adobe_PDF.print_edge_bottom
        0

        print.printer_Adobe_PDF.print_edge_left
        0

        print.printer_Adobe_PDF.print_edge_right
        0

        print.printer_Adobe_PDF.print_edge_top
        0

        print.printer_Adobe_PDF.print_evenpages
        true

        print.printer_Adobe_PDF.print_footercenter

        print.printer_Adobe_PDF.print_footerleft
        &PT

        print.printer_Adobe_PDF.print_footerright
        &D

        print.printer_Adobe_PDF.print_headercenter

        print.printer_Adobe_PDF.print_headerleft
        &T

        print.printer_Adobe_PDF.print_headerright
        &U

        print.printer_Adobe_PDF.print_in_color
        true

        print.printer_Adobe_PDF.print_margin_bottom
        0.5

        print.printer_Adobe_PDF.print_margin_left
        0.5

        print.printer_Adobe_PDF.print_margin_right
        0.5

        print.printer_Adobe_PDF.print_margin_top
        0.5

        print.printer_Adobe_PDF.print_oddpages
        true

        print.printer_Adobe_PDF.print_orientation
        0

        print.printer_Adobe_PDF.print_page_delay
        50

        print.printer_Adobe_PDF.print_paper_data
        9

        print.printer_Adobe_PDF.print_paper_height
        11.00

        print.printer_Adobe_PDF.print_paper_size_type
        0

        print.printer_Adobe_PDF.print_paper_size_unit
        0

        print.printer_Adobe_PDF.print_paper_width
        8.50

        print.printer_Adobe_PDF.print_reversed
        false

        print.printer_Adobe_PDF.print_scaling
        0.70

        print.printer_Adobe_PDF.print_shrink_to_fit
        true

        print.printer_Adobe_PDF.print_to_file
        false

        print.printer_Adobe_PDF.print_unwriteable_margin_bottom
        0

        print.printer_Adobe_PDF.print_unwriteable_margin_left
        0

        print.printer_Adobe_PDF.print_unwriteable_margin_right
        0

        print.printer_Adobe_PDF.print_unwriteable_margin_top
        0

        print.printer_Brother_HL-2030_series.print_bgcolor
        false

        print.printer_Brother_HL-2030_series.print_bgimages
        false

        print.printer_Brother_HL-2030_series.print_command

        print.printer_Brother_HL-2030_series.print_downloadfonts
        false

        print.printer_Brother_HL-2030_series.print_edge_bottom
        0

        print.printer_Brother_HL-2030_series.print_edge_left
        0

        print.printer_Brother_HL-2030_series.print_edge_right
        0

        print.printer_Brother_HL-2030_series.print_edge_top
        0

        print.printer_Brother_HL-2030_series.print_evenpages
        true

        print.printer_Brother_HL-2030_series.print_footercenter

        print.printer_Brother_HL-2030_series.print_footerleft
        &PT

        print.printer_Brother_HL-2030_series.print_footerright
        &D

        print.printer_Brother_HL-2030_series.print_headercenter

        print.printer_Brother_HL-2030_series.print_headerleft
        &T

        print.printer_Brother_HL-2030_series.print_headerright
        &U

        print.printer_Brother_HL-2030_series.print_in_color
        true

        print.printer_Brother_HL-2030_series.print_margin_bottom
        0.5

        print.printer_Brother_HL-2030_series.print_margin_left
        0.5

        print.printer_Brother_HL-2030_series.print_margin_right
        0.5

        print.printer_Brother_HL-2030_series.print_margin_top
        0.5

        print.printer_Brother_HL-2030_series.print_oddpages
        true

        print.printer_Brother_HL-2030_series.print_orientation
        0

        print.printer_Brother_HL-2030_series.print_page_delay
        50

        print.printer_Brother_HL-2030_series.print_paper_data
        9

        print.printer_Brother_HL-2030_series.print_paper_height
        11.00

        print.printer_Brother_HL-2030_series.print_paper_size_type
        0

        print.printer_Brother_HL-2030_series.print_paper_size_unit
        1

        print.printer_Brother_HL-2030_series.print_paper_width
        8.50

        print.printer_Brother_HL-2030_series.print_reversed
        false

        print.printer_Brother_HL-2030_series.print_scaling
        0.60

        print.printer_Brother_HL-2030_series.print_shrink_to_fit
        true

        print.printer_Brother_HL-2030_series.print_to_file
        false

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_bottom
        0

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_left
        0

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_right
        0

        print.printer_Brother_HL-2030_series.print_unwriteable_margin_top
        0

        privacy.donottrackheader.enabled
        true

        privacy.popups.showBrowserMessage
        false

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

        webgl.disabled
        true

  Graphics

        Adapter Description
        ATI Radeon HD 4600 Series

        Vendor ID
        0x1002

        Device ID
        0x9498

        Adapter RAM
        512

        Adapter Drivers
        aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.951.0.0

        Driver Date
        3-8-2012

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7601.17776)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        false

        GPU Accelerated Windows
        1/1 Direct3D 10

        AzureBackend
        direct2d

  JavaScript

        Incremental GC
        1

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9
        4.9

        NSS
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC

        NSS Util
        3.13.4.0
        3.13.4.0

        NSS SSL
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC

        NSS S/MIME
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC
(Reporter)

Comment 1

6 years ago
Reproduced here, with regression window:

https://bugzilla.mozilla.org/show_bug.cgi?id=746055
Depends on: 746055

Comment 2

6 years ago
How long are you away from the tab watching another tab?
Isn't this just that when you switch back to planet.mozilla.org all the images must be re-decoded again (they are discarded after 10seconds I think).

I do not have any GPU acceleration and switching back and forth (immediatelly) between PMO and other tabs is immediate.
(Reporter)

Comment 3

6 years ago
(In reply to :aceman from comment #2)
> How long are you away from the tab watching another tab?
> Isn't this just that when you switch back to planet.mozilla.org all the
> images must be re-decoded again (they are discarded after 10seconds I think).
> 
> I do not have any GPU acceleration and switching back and forth
> (immediatelly) between PMO and other tabs is immediate.

This is immediately after the tab has loaded - no delay is necessary.
> How long are you away from the tab watching another tab?
> Isn't this just that when you switch back to planet.mozilla.org all the images must be 
> re-decoded again (they are discarded after 10seconds I think).

There's now a cap on the amount of decoded image data we'll willingly keep alive, so we may end up discarding much faster than 10s.

It sounds like this is an exact dupe of bug 746055.  If my upcoming fix for bug 746055 doesn't fix this bug, we can reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746055
You need to log in before you can comment on or make changes to this bug.