Cannot change drives when using the filepicker.xul dialog

VERIFIED WONTFIX

Status

SeaMonkey
UI Design
VERIFIED WONTFIX
17 years ago
13 years ago

People

(Reporter: Jessica Blanco, Assigned: Brian Ryner (not reading))

Tracking

({qawanted})

Trunk
Future
x86
OS/2
qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
You cannot change drives when using the filepicker dialog 
(filepicker.xul). Cannot open a file from a different drive 
or save to a different drive than what the filepicker opens 
up with. Happens on all OSes using filepicker.xul.

Comment 1

17 years ago
bryner is rewriting this dialog, however i don't think anyone even thought 
about this problem (windows uses native file picker)
Assignee: asa → bryner
Component: Browser-General → XP Apps
OS: other → OS/2
QA Contact: doronr → sairuh
Hardware: Other → PC
would this occur on unix? on linux, eg, i don't have a problem opening or saving
to different *partitions*, at least... perhaps this is os/2-specific?

Comment 3

17 years ago
yes, well, it's basically os/2 specific (hence os/platform), however if we ever 
switch windows to xp filepicker, it'd appear there, I have no idea about mac (i 
hope we use nav services and avoid the issue).

mkaply: I don't remember the reason you guys didn't use a native filepicker, 
could you tell us?
Keywords: qawanted
(Assignee)

Comment 4

17 years ago
I don't think there's time for this for 0.9.  mkaply, do you think you could
help on this one?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1

Comment 5

17 years ago
This one is on our radar. We would certainly like to use the XP file picker on 
OS/2 in the future.

We do have a native filepicker. Unfortunately though when we switched widget to 
use proper component registration instead of nsSetupRegistry, we started getting 
the XP filepicker instead of the native filepicker.

Relevant code is at:

http://lxr.mozilla.org/seamonkey/source/widget/src/os2/nsWidgetFactory.cpp#252

We believe it's probably a timing issue.

For 0.9, we will simply not package nsFilePicker.js so the problem won't happen, 
but does anyone have any idea how you force one component over another in 
component registration?

Or should we not be putting nsFilePicker.js in components for OS/2 until we get 
it working?
(Assignee)

Comment 6

17 years ago
I would simply change xpfe/components/filepicker/Makefile.in to not go into the
src directory (for OS2) if you don't want the xp filepicker to be used.  Trying
to make components override each other sounds like it's asking for problems.

Comment 7

17 years ago
Silly question

Should I change filepicker/Makefile.in? Or should I just change the components 
makefile to not go into the filepicker directory at all?

Or maybe we should add a configure option for the XP filepicker?
(Assignee)

Comment 8

17 years ago
Windows goes into filepicker/res/locale, so that it can install the properties
file... you'll probably want to do the same.
(Reporter)

Comment 9

17 years ago
*** Bug 77577 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.3

Comment 10

17 years ago
Created attachment 35188 [details] [diff] [review]
Don't go into src on OS/2

Comment 11

17 years ago
r=cls
(Assignee)

Comment 12

17 years ago
Pushing this out, we have no plans to turn on the xul filepicker on any non-unix
platforms in the 0.9.3 timeframe.
Target Milestone: mozilla0.9.3 → mozilla1.0
(Assignee)

Comment 13

17 years ago
using the xul filepicker for non-unix systems really isn't a high priority...
Target Milestone: mozilla1.0 → Future

Comment 14

16 years ago
Brian,

Do you think this is something we will ever want for any platform besides OS/2?

If not, we can kill this bug - we rewrote our file picker on OS/2 and it works 
very well so we don't need to use the XP one anymore.
(Assignee)

Comment 15

16 years ago
doubtful.  let's kill it.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 16

16 years ago
Verify. we don't need this anymore.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.