Handle missing dhcp_do_request_renew() in newer SDK version

RESOLVED WONTFIX

Status

()

Core
DOM: Device Interfaces
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: swu, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The
(Reporter)

Comment 1

6 years ago
Sorry for previous incomplete comment.  :p

In B2G github there is a black screen issue related to missing dhcp_do_request_renew().
Please reference:
    https://github.com/andreasgal/B2G/issues/273
    https://github.com/andreasgal/B2G/issues/261

The gonk function dhcp_do_request_renew() no longer exists in libnetutils.so since SDK version 15.

In dom/system/gonk/systemlibs.js and dom/wifi/libnetutils.js, there are already implementation to avoid using dhcp_do_request_renew() by checking SDK version defined in property "ro.build.version.sdk".

However, if the libnetutils.so is pulled from device with stock FW built by newer SDK version, instead of building from source, then this checking would be incorrect(current gonk SDK version is 10).  We should find a way to handle this condition.
Summary: systemlibs.js testing only → Handle missing dhcp_do_request_renew() in newer SDK version
Are we trying to build a GB gonk with ICS blobs?
(In reply to Shian-Yow Wu from comment #1)
> However, if the libnetutils.so is pulled from device with stock FW built by
> newer SDK version, instead of building from source, then this checking would
> be incorrect(current gonk SDK version is 10).  We should find a way to
> handle this condition.

With which device is this an issue?
(Reporter)

Comment 4

6 years ago
There are 2 cases, both from SGS2 GB firmware.

For case 1, 'nm -D libnetutils.so' on stock firmware doesn't show dhcp_do_request_new() function.  The build.info shows ro.build.version.sdk=10 and ro.build.version.release=2.3.3.

For case 2, unable to reproduce again to get more information.

So the initial guess that stock FW built by newer SDK version might be wrong.
(Reporter)

Comment 5

6 years ago
No longer tracking SGS2 GB issues.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.