Cannot sign into Persona using native Marketplace app

RESOLVED DUPLICATE of bug 729853

Status

Firefox Graveyard
Webapp Runtime
RESOLVED DUPLICATE of bug 729853
6 years ago
2 years ago

People

(Reporter: Mardak, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Assuming the user installed the Marketplace app from the Marketplace website, the user would end up needing to log into Persona again from the native Marketplace app.

I thought one of the goals was that apps wouldn't need to require users to log in because apps are associated with a Persona account anyway. ?
(Reporter)

Comment 1

6 years ago
Sounds like I was wrong expecting auto-logged-in-ness to a Persona account for a given app.

Either way, bug 746217 prevents any popup windows from opening and bug 729853 is for different-domain popups.

One potential solution is to have Persona detect exceptions on window.open and fall back to an iframe login approach.

Although I'm not sure if Persona had a requirement of non-in-content/lightbox-like login flows.. ?
Depends on: 729853, 746217
Summary: Native Marketplace app requires signing in to Persona → Cannot sign into Persona using native Marketplace app
Is this a duplicate of bug 729853? This issue I think gets fixed if bug 729853 gets fixed.
(Reporter)

Comment 3

6 years ago
Bug 729853 (or bug 746217) could be one way to fix this. Another way is to have Persona fall back to an in-content login flow if window.open fails. This bug is tracking the desired log-into-Persona functionality.
Let's duplicate against bug 729853, given that browser ID (persona) follows this functionality for "pop-ups" throughout anyplace that uses it. The other option is at the choice of the browser ID team.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729853

Updated

6 years ago
No longer depends on: 729853, 746217
(Assignee)

Updated

6 years ago
Component: Desktop Runtime → Webapp Runtime
Product: Web Apps → Firefox
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.