disable the screen resolution changing on android for jsreftest and crashtest, leave it on for reftest

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
7 years ago
7 months ago

People

(Reporter: jmaher, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile] live)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

7 years ago
the jsreftests and crashtests do not require us to compare canvas images that use 800x1000.  Right now in our sut_tools, we do a blanket resolution change for all reftest harness tests.
(Reporter)

Comment 1

7 years ago
when doing this, we would need to add the '--ignore-window-size' argument to the reftest command line arguments.
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: release → catlee
Whiteboard: [mobile]
(Reporter)

Comment 2

7 years ago
Created attachment 616757 [details] [diff] [review]
sut_tools - only adjust the resolution for reftest (1.0)

simple patch to only adjust/verify resolution for reftest, not crashtest or jsreftest.
Attachment #616757 - Flags: review?(bear)

Updated

7 years ago
Attachment #616757 - Flags: review?(bear) → review+
(Reporter)

Comment 3

7 years ago
the only other thing needed is to add '--ignore-window-size' to the arguments for jsreftest and crashtest.
Created attachment 616961 [details] [diff] [review]
add --ignore-window-size to jsreftest and creashtest
Attachment #616961 - Flags: feedback?(jmaher)
(Reporter)

Comment 5

7 years ago
Comment on attachment 616961 [details] [diff] [review]
add --ignore-window-size to jsreftest and creashtest

Review of attachment 616961 [details] [diff] [review]:
-----------------------------------------------------------------

in general these look like desktop unittests?  Is there a way to get this in the mobile-reftest-mixin?

::: steps/unittest.py
@@ +341,3 @@
>          elif suite == 'crashtest-ipc':
>              return ['--setpref=browser.tabs.remote=true',
> +                    '--ignore-window-size',

we don't run crashtest-ipc on mobile.

@@ +365,4 @@
>                      'jsreftest/tests/jstests.list']
>          elif suite == 'reftest-sanity':
> +            return ['--ignore-window-size',
> +                    'reftest/tests/layout/reftests/reftest-sanity/reftest.list']

we shouldn't change this.
Attachment #616961 - Flags: feedback?(jmaher) → feedback-
(Reporter)

Comment 6

7 years ago
Created attachment 617034 [details] [diff] [review]
add --ignore-window-size to remote jsreftest/crashtest commandline (1.0)

my attempt at this.
Attachment #616961 - Attachment is obsolete: true
Attachment #617034 - Flags: feedback?(bear)
Comment on attachment 617034 [details] [diff] [review]
add --ignore-window-size to remote jsreftest/crashtest commandline (1.0)

looks good, but what is the piece that is showing just above your patch?
Attachment #617034 - Flags: feedback?(bear) → feedback+
(Reporter)

Comment 8

7 years ago
oh interesting...maybe I am editing the wrong place.  I don't see --ignore-window-size when looking at the logs.  Maybe next week we can decipher this.
Assignee: nobody → jmaher
(Reporter)

Comment 9

7 years ago
in both repositories: buildbotcustom and buildbot-configs, I am unable to figure out how we run remotereftest.py without the --ignore-window-size.  When I look on tbpl, it indicates that we are not running with that cli flag, but in unittest.py it looks like we are:
http://mxr.mozilla.org/build/source/buildbotcustom/steps/unittest.py#965

I suspect either of these two options to explain my confusion:
1) I am not looking in the correct repository
2) What is checked in is NOT running on the foopies
catlee pointed out that what matters is not mxr...unittest.py, but http://hg.mozilla.org/build/buildbotcustom/annotate/production-0.8/steps/unittest.py#l965 - apparently --ignore-window-size got backed out on production in http://hg.mozilla.org/build/buildbotcustom/diff/8967863f12b6/steps/unittest.py but not on default.
(Reporter)

Comment 11

7 years ago
Created attachment 617887 [details] [diff] [review]
remove global --ignore-window-size and add option for crashtest/jsreftest (1.0)

revert the change to the repo to have --ignore-window-size on by default.  Add this option in for jsreftest and crashtests.
Attachment #617034 - Attachment is obsolete: true
Attachment #617887 - Flags: review?(armenzg)
(Assignee)

Comment 12

7 years ago
Comment on attachment 617887 [details] [diff] [review]
remove global --ignore-window-size and add option for crashtest/jsreftest (1.0)

This looks good. Thanks jmaher.
Attachment #617887 - Flags: review?(armenzg) → review+
(Assignee)

Updated

7 years ago
Assignee: jmaher → armenzg
(Assignee)

Comment 13

7 years ago
jmaher, what should I be looking for?
http://dev-master01.build.scl1.mozilla.com:8043/one_line_per_build

I have few left jobs running that were run by bad tegras.
(Reporter)

Comment 14

7 years ago
I am looking for all green jobs.  

It looks like the jobs are failing for other reasons (mostly the updatesut.py step).  All we need is 1 cycle of green to prove this works.  Preferably with an updated mozilla-central build.
(Assignee)

Comment 15

7 years ago
I am re-testing this again together with the sut agent 1.08 upgrade.
I should have results tomorrow morning.
(Assignee)

Comment 16

7 years ago
jmaher is going to look at the green jobs in here:
http://tinderbox.mozilla.org/showbuilds.cgi?tree=MobileTest
(Assignee)

Comment 17

7 years ago
jmaher checked this and I believe he gave clearance to deploy. Can you please confirm?

I would like to deploy this or bug 750744 tomorrow and do the other one on Monday.
I think this one is easier to recover in case anything goes wrong and the other one gives us Tuesday to recover if we need too.
(Reporter)

Comment 18

7 years ago
confirmed!
(Assignee)

Comment 19

7 years ago
reftest [1] did increase the resolution while jsreftest [2] did not.
These two steps differ in 210 seconds which is 3.5 minutes :)

[1]
python /builds/sut_tools/config.py 10.250.49.16 reftest
...
connecting to: 10.250.49.16
reconnecting socket
devroot /mnt/sdcard/tests
results: {'screen': ['X:1024 Y:768']}
current resolution X:1024 Y:768
/builds/tegra-029/test/../proxy.flg
results: {'os': ['harmony-eng 2.2 FRF91 20110202.102810 test-keys']}
results: {'screen': ['X:1024 Y:768']}
INFO: we have a current resolution of 1024, 768
INFO: adjusting screen resolution to 1600, 1200 and rebooting
DEBUG: gCallbackData is:  on port: 50029
Creating server with 10.250.48.200:50029
Calling disconnect on callback server
. Got data back from agent: System rebooted


Shutting down server now
System rebooted


Waiting for tegra to come back...
Try 1
reconnecting socket
devroot /mnt/sdcard/tests
results: {'screen': ['X:1600 Y:1200']}
current resolution X:1600 Y:1200
program finished with exit code 0
elapsedTime=210.825854

[2] 
python /builds/sut_tools/config.py 10.250.49.16 jsreftest
...
connecting to: 10.250.49.16
reconnecting socket
devroot /mnt/sdcard/tests
results: {'screen': ['X:1024 Y:768']}
current resolution X:1024 Y:768
program finished with exit code 0
elapsedTime=0.262667
(Assignee)

Updated

7 years ago
Whiteboard: [mobile] → [mobile] to be deployed 2012/05/11
(Assignee)

Updated

7 years ago
Priority: -- → P1
(Assignee)

Updated

7 years ago
Duplicate of this bug: 737427
(Assignee)

Comment 21

7 years ago
Comment on attachment 616757 [details] [diff] [review]
sut_tools - only adjust the resolution for reftest (1.0)

http://hg.mozilla.org/build/tools/rev/5b54bae472ab
Attachment #616757 - Flags: checked-in+
(Assignee)

Comment 22

7 years ago
Comment on attachment 617887 [details] [diff] [review]
remove global --ignore-window-size and add option for crashtest/jsreftest (1.0)

http://hg.mozilla.org/build/buildbotcustom/rev/e0c0fd23f72a
Attachment #617887 - Flags: checked-in+
(Assignee)

Comment 23

7 years ago
This is now live.

We might see some jobs fail because I had to clobber the tools checkout on the foopies and restore the symlinks.
Whiteboard: [mobile] to be deployed 2012/05/11 → [mobile] live
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Armen please confirm this is deployed everywhere, I was checking on foopy23 for an unrelated problem on tegra-266 (verify.py unknown errors) and I noticed that tools/ is outdated here.

I'm not sure if this is one-off or everywhere...

foopy23:~ cltbld$ hg -R /builds/tools in
comparing with http://hg.mozilla.org/build/tools
searching for changes
changeset:   2530:513ae0365f85
user:        Aki Sasaki <asasaki@mozilla.com>
date:        Wed May 09 17:20:00 2012 -0700
summary:     Added tag FENNEC_14_0b1_RELEASE, FENNEC_14_0b1_BUILD2 for changeset c0122cac3804

changeset:   2531:cfe229dff313
tag:         FENNEC_14_0b1_BUILD3
tag:         FENNEC_14_0b1_RELEASE
user:        Ben Hearsum <bhearsum@mozilla.com>
date:        Fri May 11 03:18:25 2012 +0800
summary:     Remove now-dead sjc1 masters from production-masters.json; fix datacentre attribute on
new schedulers. r=catlee

changeset:   2532:77f3f141ad0b
user:        Aki Sasaki <asasaki@mozilla.com>
date:        Thu May 10 16:28:56 2012 -0700
summary:     Added tag FENNEC_14_0b1_RELEASE, FENNEC_14_0b1_BUILD3 for changeset cfe229dff313

changeset:   2533:18227ad5ca08
user:        John Hopkins <jhopkins@mozilla.com>
date:        Fri May 11 08:48:19 2012 -0400
summary:     Do thunderbird release builds on bm34 (Bug 748157 - Add Thunderbird to production-*.jso
n). r=catlee

changeset:   2534:573d357258bb
user:        John Hopkins <jhopkins@mozilla.com>
date:        Fri May 11 09:36:20 2012 -0400
summary:     Enable bm34. r=bhearsum

changeset:   2535:5b54bae472ab
tag:         THUNDERBIRD_13_0b2_BUILD1
user:        Joel Maher <jmaher@mozilla.com>
date:        Fri May 11 10:43:03 2012 -0400
summary:     Bug 746260 - disable the screen resolution changing on android for jsreftest and crasht
est, leave it on for reftest. r=bear

changeset:   2536:e3e998673505
tag:         THUNDERBIRD_13_0b2_RELEASE
user:        John Hopkins <jhopkins@mozilla.com>
date:        Fri May 11 12:12:36 2012 -0400
summary:     Added tag THUNDERBIRD_13_0b2_BUILD1 for changeset 5b54bae472ab

changeset:   2537:8475773f8255
user:        John Hopkins <jhopkins@mozilla.com>
date:        Fri May 11 12:12:41 2012 -0400
summary:     Added tag THUNDERBIRD_13_0b2_RELEASE for changeset e3e998673505

changeset:   2538:f258181830f1
user:        Armen Zambrano Gasparnian <armenzg@mozilla.com>
date:        Fri May 11 12:26:52 2012 -0400
summary:     Bug 754297. add sys.stdout.flush() to sut_tools' scripts. r=bear

changeset:   2539:fdf190203a10
user:        Justin Wood <Callek@gmail.com>
date:        Fri May 11 15:04:59 2012 -0400
summary:     Bug 747641 - tegra-224 problem tracking. rs+=bear

changeset:   2540:c98cc48b759e
tag:         FENNEC_13_0b2_BUILD2
tag:         FENNEC_13_0b2_RELEASE
user:        Justin Wood <callek@mozilla.com>
date:        Fri May 11 16:52:32 2012 -0400
summary:     No Bug - List tegra-172 in Unassigned block of foopies.sh

changeset:   2541:540c331a82b0
tag:         tip
user:        Aki Sasaki <asasaki@mozilla.com>
date:        Fri May 11 16:05:31 2012 -0700
summary:     Added tag FENNEC_13_0b2_BUILD2, FENNEC_13_0b2_RELEASE for changeset c98cc48b759e

foopy23:~ cltbld$
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 25

7 years ago
This was my bad.
I always thought we only had up to foopy22.
I updated the tools repo and it is updated to the same revision as the others (f258181830f1).


The only other foopy I did not touch/clobber was foopy05 knowing that it was a staging one and you had changes in there. IIRC I let you know this on IRC.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.