Closed Bug 746345 Opened 8 years ago Closed 7 years ago

thunderbird menus freeze up after waking from hibernation starting in TB11 (not IDLE related)

Categories

(Thunderbird :: Mail Window Front End, defect)

11 Branch
x86_64
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: crueby1, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [has protocol log][regression:TB11b1])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

With Thunderbird 11.0.1 running, hibernated my Win-XP 64bit machine, then woke it back up.


Actual results:

thunderbird menu buttons take 5-10 seconds to do anything when clicked, moving mouse over menus does not highlight them like normal. Clicking on get mail makes it lock up for about 10 seconds. If I have the new mail notification display turned on, and new mail was there when machine woke up, the notification box shows up with nothing in it, and wont go away. If I shut down thunderbird (also have to kill a task for it if notification display is on), and start it again, it works normally till next hibernate.


Expected results:

Should have worked normally after the wake from hibernation. This issue did not exist till upgrading to version 11.0.1.
OS: Windows Server 2003 → Windows XP
this might be due to tbird checking while network is not yet restored.
what happens if you have put tbird in offline state before hibernate occurs?
I will try that - it does not matter how long I wait after the wake from hibernate, it stays in the flaky state until I exit thunderbird and restart it. It will still get mail, but it takes a long time, and the menus are all unresponsive - in three ways: mousing over buttons does not do the normal highlighting, clicking on them works but takes a very long time, and in drop down menus, any menu that has a submenu also takes a very long time to draw itself.
update - put thunderbird into offline mode, then hibernated the PC, woke it
up, and waited for the OS to be fully up and ready. Then moved the mouse over
the menu buttons, which were unresponsive. Menus all behaved just like before, so
being in offline mode during the hibernate made no difference. Even the button
to put it in online mode was unresponsive. Then shut down/restarted thunderbird, and it was all normal again.

Any other experiments or info you would like please let me know.
Do you use IMAP account?
If yes, do you enable IDLE command use for IMAP accounts? (Server Settings/Advanced)
Do you enable automatic/periodical new mail check for IMAP accounts?
If IDLE command is enabled and automatic/periodical new mail check is enabled,
try "disabling IDLE command use".
Will frequency of your problem be reduced by it?

What is type of your network? Cabled LAN with router type HAB/Modem? Wifi like one? "PPP on IP" type?(dialer is used to establich connection to ISP).
I do not use IMAP - am set up for POP server through roadrunner. 
Changing it not to automatically check for new mail made no difference,
still has bad behavior after wake from hibernate.

The network is a cable modem coming into the house, then to a Belkin N300
router which is cabled to desktop PC.

Some other information gained from experimenting, dont know if any of it helps:
- tried disabling add-ons and extensions, no change
- made sure all add-ons/extensions were up to date

Did notice one thing that I had not before: the same problem with the mouse-hover
over buttons not highlighting them also exists in my firefox, though the buttons there still take effect right away, where in the email app there is a long delay.
Does that point to something in the rendering engine rather than the email download? 
Also, none of this happened in the earlier version of thunderbird, just started after the latest updates. Are there any sequences of  earlier version(s) of either tbird or firefox that I should try installing, then update them one by one, that would help diagnose this?
I would first try 11.0 - we introduced two changes i .1 so letting us know what version you were running before hand would be helpfull.

If the issue is between 10 and 11 then follow http://www.rumblingedge.com/2009/02/24/howto-find-regression-windows-through-manual-binary-search/ to try to figure out when we broke.

Also getting us a stack trace when Thunderbird is slow might help (see https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg , replace firefox by thunderbird).

Also are the drivers on your machine up to date ?

Do you have any kind of anti-virus/firewall running ?
I was able to download and install 11.0, same problem there. I was not sure where to get the version 10 installers - only one I could find was 10.0.3esr, which I installed, and it does not show the problem at all. Where can I find the normal version 10 releases? Hopefully what I found with this one helps.

The drivers and OS are all up to date. There is anti-virus/firewall running: AVG Internet Security 2012. The email plugins/addons are disabled, since they show as not compatible. I did try and disable all the AVG stuff, made no difference.

One thing that I still find interesting, which I noted the other day in previous comment, is that Firefox also shows odd behavior with the buttons - the mouse-hover behavior is gone, but it does not have the long lag/hang when clicking on its menus like thunderbird does. Seems like a clue - I dont know what is common between the two apps, I assume the underlying layers are shared. I am running 11.0 firefox currently.
(In reply to Chris Rueby from comment #7)
> The email plugins/addons are disabled, since they show as not compatible.

Many of plugins are not shown as "not compatible".
Did you actually disable all plugins at Tools/Addons/Plugins of Tb?
(confusing but big "Enable" button == Indicator of Disabled status...)

IIRC, hidden plugin.disable was set to true by default in some releases to bypass performance related issues, but it was done only in a few releases of Tb 9 or 10.
WADA - Yes, went through and disabled them myself, restarted the app, hibernated/woke, and same issues showed. Re-enabled them, did same, same results.
I'm seeing this as well, on Win XP (SP3) 32bit.  I also see Firefox issues (bug 711106).

The "Get mail" menu is weird: if I click on the drop-down arrow (wanting to get all new messages) nothing is drawn until I move the mouse, at which point I can click "get all" and Thunderbird downloads mail.

Another symptom is that selecting a message doesn't change its status to read, even waiting a few minutes.
One thing I forgot to mention: for me the problem started when I upgraded to Thunderbird 11.0 direct from version 9; I never used version 10.
Another thing I tried over the weekend was freeing up some disk space on C: and de-fragmenting the drive.  This seems to have reduced the severity of the problem slightly, but not completely fixed it.

When I next get a chance I'll try re-installing Thunderbird from scratch with a new profile and see if the problem still occurs.  It does occur when running with all add-ons and plugins disabled though.
Whiteboard: [has protocol log]
nothing interesting in the log that I can see. The UI thread is in DoProcessNextNativeEvent, which I assume is some windows native event.
(In reply to bugzilla.mozilla.org from comment #13)
> When I next get a chance I'll try re-installing Thunderbird from scratch
> with a new profile and see if the problem still occurs.  It does occur when
> running with all add-ons and plugins disabled though.

I did this over the weekend. Uninstalled, moved Thunderbird's folder in "Application Data" away, installed a fresh copy of version 13.0, created a new profile with a single IMAP account, problem still exists :(

Just re-read the thread and noticed the advice for IMAP in comment #4, so I've disabled IDLE for all accounts and we'll see what happens on the next resume...
Alas, it still happens with IDLE disabled on all (4) IMAP accounts.  It also still happens in safe mode.  It's possibly slightly worse with IDLE disabled, and slightly better in safe mode, but it's hard to tell as the symptoms aren't easily quantifiable, and do vary anyway.

It feels basically like Thunderbird is walking through treacle - there's a very long lag before it responds to your actions, on the order of minutes, but it does seem to respond (at least to most things) eventually.  The same effect is seen in Firefox too.  For instance, if I select the Tools menu (and move the mouse to get it to appear) and then Add-ons, the title bar changed immediately to reflect this, but the Add-ons manager didn't appear until about a minute later.  I see the same when changing tab in Firefox - the title bar changes immediately, but the tab content doesn't appear until a few minutes later, typically.
Chris, does disabling AVG help?
Summary: thunderbird menus freeze up after waking from hibernation → thunderbird menus freeze up after waking from hibernation starting in TB11 (not IDLE related)
No difference with AVG on or off. One thing that I see a lot of people assuming is that the communications is the cause of this. But, since it happens with both thunderbird AND firefox, whether it is trying to access anything on the remote sites or not, is it really communications, or something not resuming right in the menuing/gui system itself?
Hibernate and sleep have been known to cause issues with networking, so it would not be surprising for someone to raise the subject of networking. :)   
But until the cause is found, all bets are off
I have exactly the same problem (many of the symptoms described above), starting from several versions ago maybe even TB v9. It seems to have got worse if anything with the latest version (13). However, I only see the problems on my netbook (Eee PC 1000HE Intel Atom running Windows XP). I have no problems at all on my ancient desktop (Pentium IV, Windows XP) or my laptop (Dell D610, Windows XP).

It may be unconnected, but looking at the version change information, I do remember noticing that there was a significant change to support of some of the rendering routines (from TB9 onwards I think). The troubleshooting information on all my computers indicates that the "WebGL rendererer" and "GPU accelerated windows" are not supported. I'm happy to upload any diagnostic info that may help.

Chris - one helpful thing I have discovered is that when TB pops up a blank notification box, you can still get rid of this without resorting to Task Manager by clicking where you know the "close window" X should be.

Richard
I'm in principle happy to do some bisecting to find the changeset responsible.  However, I don't have facilities to build from source on this machine, and couldn't figure out where to start from browsing http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/, so if you can point me at a useful range that'd be great. It'll take a while to do though due to the nature of the problem.
Range is before  	2012-04-17  after that it's difficult to see when it started. I would go back 6 month back and see from there.
Same problem here with TB 14.0 une Windows 7.
Just close TB window, re-execute it and it freezes, no window re-opens.
Must restart Windows.
(In reply to bugzilla.mozilla.org from comment #22)
> I'm in principle happy to do some bisecting to find the changeset
> responsible.  However, I don't have facilities to build from source on this
> machine, and couldn't figure out where to start from browsing
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/, so if you can
> point me at a useful range that'd be great. It'll take a while to do though
> due to the nature of the problem.

I've determined that problem exists in the first Thunderbird 11 Beta1 release (it is not present in the last stable 10 release 10.0.2 which I have been running happily for weeks now). This included the step of moving tabs to above the menu, so perhaps there were some major rehacks going on rather than just switching to the next version of Gecko.

I'm happy to test other versions but am not able to build versions myself. (These versions I picked up from the oldapps.com website.)

Richard
I can also confirm this issue with TB16 (and several earlier versions) on WinXP and Asus EeePC 1000H. It also happens to FireFox, see bug 765215 and bug 788171. Apparently the issue was introduced with the following commit affecting the refresh timer:
http://hg.mozilla.org/mozilla-central/rev/63bff373cb94

Reverting this commit fixed the issue for those seeing it with FF (see bug 765215, comment 46 and 47 etc).
A possible explanation is that clock skew due to hibernation may not be handled properly by the new code (see bug 765215, comment 61) - and affects those systems where the clock is somehow jumping backwards when waking up from hibernation.

When the issue occurrs I see it with both, FF and TB at the same time - while no other application is affected. Also seems to suggest it is caused by a timer/clock issue - hence affecting both.

(I really hope someone finally picks up the issue. It's driving my nuts - I'm seeing it several times a day - for several months now...)
Thorsten B,

Great report - hope someone in the know can try to fix (I'm happy to test out on my Asus 1000HE.. though note that it often takes several hibernate cycles for it to kick in, so feedback may not be immediate).

In the meantime I have found Thunderbird 10.0.2 to be very stable and will probably stick to that into perpetuity unless its fixed. There aren't many features (or obvious bug fixes) in the newer Thunderbird that I use anyway and as development is somewhat parked I don't foresee there being many more.

One thing holding me back from buying a tablet is finding a mail tool as usable as Thunderbird.. be nice to have an Android (or possibly iOS) version, but understand that's quite a different platform to port to!

Richard
There is some movement/progress being made in at least one core bug report which might help with this. Not sure yet how quickly it will move forward.
Depends on: 765215
Unfortunately the machine which exhibited this has now suffered hard disk failure and been retired, so I can't test a fix.  However, the clock on the machine did have a tendency to drift so the diagnosis seems plausible.
I can still reproduce it with TB. I already verified the related fix with a FireFox nightly. Is the fix already available with a Thunderbird nightly? Which one? I'd be more than happy to test...
I also have an Asus Eee 1000H with this problem and could test it.
(In reply to ThorstenB from comment #30)
> I can still reproduce it with TB. I already verified the related fix with a
> FireFox nightly. Is the fix already available with a Thunderbird nightly?
> Which one? I'd be more than happy to test...

you are thinking of bug 765215 - fixed in firefox 20 2012-12-24.
This fix should be in thunderbird 20.0a2 available from https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2013-01-30-04-20-01-comm-aurora/

Can you please test it?
Flags: needinfo?(crueby1)
also available as earlybird at http://www.mozilla.org/en-US/thunderbird/channel/
Whiteboard: [has protocol log] → [has protocol log][regression:TB11b1]
I just retested it on the machine I originally found the problem on, using the earlybird version link that Wayne posted - works perfectly now! 

Is the same fix in a Firefox version yet? I had gone back to an earlier ESR version on both FF and TB to get around this problem. If fixed in both I'll upgrade again.
Flags: needinfo?(crueby1)
(In reply to Wayne Mery (:wsmwk) from comment #32)
> you are thinking of bug 765215 - fixed in firefox 20 2012-12-24.

Right, that was the fix which worked for FF. I'm now testing TB 20a2 - looks good so far.

(In reply to Chris Rueby from comment #34)
> Is the same fix in a Firefox version yet?

It's fixed for FF 20 (still in Aurora channel).
Can also confirm the fix here. Finally FF and TB are both working fine again. Wohoo! ;-)
If you can't reproduce it anymore, please mark this bug as WORKSFORME. Thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.