Last Comment Bug 746382 - Save a copy of mozconfig in objdir
: Save a copy of mozconfig in objdir
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Steve Fink [:sfink] [:s:]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-17 16:10 PDT by Steve Fink [:sfink] [:s:]
Modified: 2012-04-25 07:24 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
save a copy of the mozconfig file in the objdir (921 bytes, patch)
2012-04-17 16:10 PDT, Steve Fink [:sfink] [:s:]
khuey: review+
Details | Diff | Review

Description Steve Fink [:sfink] [:s:] 2012-04-17 16:10:15 PDT
I have a cron job that scans through all mozilla repos I have checked out and looks in each one for an objdir. For each objdir, it triggers a nightly rebuild of whatever is in the source tree. (Some source trees also autoupdate before this step.) Currently, I have:

0 1 * * *       for o in src/*/.hg/../obj*; do ( cd $o && make -j8 -s -k > nightly-build.log 2>&1 ); done

Note that this relies on my own naming convention of $srcdir/obj or $srcdir/obj-*.

However, this breaks when configure.in changes, because I need to re-do a make -f client.mk. And I don't know what mozconfig to use for a given objdir. And I often have multiple mozconfig files lying around, some of them sharing objdirs, so I don't really want to loop over all mozconfigs instead of all objdirs.

Ok, so this is really my own problem, but if client.mk were kind enough to store the mozconfig used, then I could just use that and this would all work.
Comment 1 Steve Fink [:sfink] [:s:] 2012-04-17 16:10:26 PDT
Created attachment 615931 [details] [diff] [review]
save a copy of the mozconfig file in the objdir

this keeps a copy of whatever mozconfig file you used in $objdir/.mozconfig

I may be doing it the wrong way and/or using a dumb filename, but this would work for what I want.
Comment 2 Steve Fink [:sfink] [:s:] 2012-04-24 17:03:11 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/6c39b78d67c0
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-25 07:24:30 PDT
https://hg.mozilla.org/mozilla-central/rev/6c39b78d67c0

Note You need to log in before you can comment on or make changes to this bug.