android.view.ViewRootImpl$CalledFromWrongThreadException: Only the original thread that created a view hierarchy can touch its views at android.view.ViewRootImpl.checkThread(ViewRootImpl.java) at android.widget.ImageView.invalidateDrawable(ImageView.java)

VERIFIED FIXED in mozilla14

Status

()

defect
P1
critical
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: scoobidiver, Assigned: liuche)

Tracking

({crash})

unspecified
mozilla14
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 beta+)

Details

(Whiteboard: [native-crash], sync, crash signature, )

There's one crash in 14.0a1/20120417: bp-ec504f72-1a32-4d13-b70a-dcca92120417.

android.view.ViewRootImpl$CalledFromWrongThreadException: Only the original thread that created a view hierarchy can touch its views.
	at android.view.ViewRootImpl.checkThread(ViewRootImpl.java:4039)
	at android.view.ViewRootImpl.invalidateChild(ViewRootImpl.java:722)
	at android.view.ViewRootImpl.invalidateChildInParent(ViewRootImpl.java:771)
	at android.view.ViewGroup.invalidateChild(ViewGroup.java:4005)
	at android.view.View.invalidate(View.java:8576)
	at android.view.View.invalidate(View.java:8527)
	at android.widget.ImageView.invalidateDrawable(ImageView.java:189)
	at android.graphics.drawable.Drawable.invalidateSelf(Drawable.java:350)
	at android.graphics.drawable.Drawable.setVisible(Drawable.java:548)
	at android.widget.ImageView.onDetachedFromWindow(ImageView.java:1060)
	at android.view.View.dispatchDetachedFromWindow(View.java:9818)
	at android.view.ViewGroup.dispatchDetachedFromWindow(ViewGroup.java:2266)
	at android.view.ViewGroup.dispatchDetachedFromWindow(ViewGroup.java:2266)
	at android.view.ViewGroup.removeAllViewsInLayout(ViewGroup.java:3717)
	at android.view.ViewGroup.removeAllViews(ViewGroup.java:3672)
	at com.android.internal.policy.impl.PhoneWindow.setContentView(PhoneWindow.java:249)
	at android.app.Activity.setContentView(Activity.java:1835)
	at org.mozilla.gecko.sync.setup.activities.SetupSyncActivity.displayAbort(SetupSyncActivity.java:253)
	at org.mozilla.gecko.sync.jpake.JPakeClient.displayAbort(JPakeClient.java:257)
	at org.mozilla.gecko.sync.jpake.JPakeClient.abort(JPakeClient.java:249)
	at org.mozilla.gecko.sync.jpake.stage.GetRequestStage$1.handleError(GetRequestStage.java:83)
	at org.mozilla.gecko.sync.jpake.stage.GetRequestStage$2.handleHttpIOException(GetRequestStage.java:164)
	at org.mozilla.gecko.sync.net.BaseResource.execute(BaseResource.java:257)
	at org.mozilla.gecko.sync.net.BaseResource.go(BaseResource.java:275)
	at org.mozilla.gecko.sync.net.BaseResource.get(BaseResource.java:281)
	at org.mozilla.gecko.sync.jpake.stage.GetRequestStage$GetStepTimerTask.run(GetRequestStage.java:194)
	at java.util.Timer$TimerImpl.run(Timer.java:284)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=android.view.ViewRootImpl%24CalledFromWrongThreadException%3A+Only+the+original+thread+that+created+a+view+hierarchy+can+touch+its+views.+at+android.view.ViewRootImpl.checkThread%28ViewRootImpl.java%29
Whiteboard: [native-crash] → [native-crash], sync
Component: General → Android Sync
Product: Fennec Native → Mozilla Services
QA Contact: general → android-sync
Version: Trunk → unspecified
Assignee: nobody → liuche
blocking-fennec1.0: --- → ?
mobile triage: p1, nasty issue
Priority: -- → P1
Whiteboard: [native-crash], sync → [native-crash], sync, [patch waiting]
blocking-fennec1.0: ? → beta+
https://hg.mozilla.org/integration/mozilla-inbound/rev/3a9db9c55f14
Status: NEW → ASSIGNED
Whiteboard: [native-crash], sync, [patch waiting] → [native-crash], sync
Target Milestone: --- → mozilla14
https://hg.mozilla.org/mozilla-central/rev/3a9db9c55f14
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I cannot reproduce this issue on the latest Nightly build. Scoobidiver, do you have any str for this bug?

--
Firefox 15.0a1 (2012-04-25)
Device: Samsung Galaxy S (Captivate)
OS: Android 2.2
(In reply to Cristian Nicolae (:xti) from comment #4)
> Scoobidiver, do you have any str for this bug?
No. It was filed based on crash stats.
(In reply to Scoobidiver from comment #5)
> No. It was filed based on crash stats.

I don't see it on the latest Nightly. Should we close it as verified fixed then?
The latest crash happened in 14.0b2 after the patch landed, but the stack is slightly different from the one in comment 0: bp-a464020e-7a88-47ee-8c93-e7cf62120522.
Status: RESOLVED → VERIFIED
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.