Last Comment Bug 746554 - Dropbox and YouSendIt preference panes need margins next to used/unused storage counts
: Dropbox and YouSendIt preference panes need margins next to used/unused stora...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Preferences (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Mike Conley (:mconley)
:
:
Mentors:
: 746596 (view as bug list)
Depends on:
Blocks: BigFiles 746307
  Show dependency treegraph
 
Reported: 2012-04-18 06:54 PDT by Mike Conley (:mconley)
Modified: 2012-04-20 12:12 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Notice the crammed together labels and values. (20.43 KB, image/png)
2012-04-18 06:54 PDT, Mike Conley (:mconley)
no flags Details
WIP Patch v1 (4.72 KB, patch)
2012-04-18 12:39 PDT, Mike Conley (:mconley)
no flags Details | Diff | Splinter Review
Patch v1 (5.92 KB, patch)
2012-04-18 13:32 PDT, Mike Conley (:mconley)
richard.marti: review+
bwinton: ui‑review+
mozilla: approval‑comm‑aurora+
Details | Diff | Splinter Review
Ubuntu (63.07 KB, image/png)
2012-04-18 13:33 PDT, Mike Conley (:mconley)
no flags Details
OSX (67.20 KB, image/png)
2012-04-18 13:42 PDT, Mike Conley (:mconley)
no flags Details
Windows 7 (70.11 KB, image/png)
2012-04-18 13:45 PDT, Mike Conley (:mconley)
no flags Details
Windows XP (33.35 KB, image/png)
2012-04-18 13:47 PDT, Mike Conley (:mconley)
no flags Details

Description Mike Conley (:mconley) 2012-04-18 06:54:24 PDT
Created attachment 616109 [details]
Notice the crammed together labels and values.

The used / unused storage storage counts seem pretty crammed together with their labels.  Seems to be true on each platform.  We should space those out.

See screenshot.
Comment 1 Andreas Nilsson (:andreasn) 2012-04-18 09:06:49 PDT
*** Bug 746596 has been marked as a duplicate of this bug. ***
Comment 2 Mike Conley (:mconley) 2012-04-18 12:39:07 PDT
Created attachment 616249 [details] [diff] [review]
WIP Patch v1
Comment 3 Mike Conley (:mconley) 2012-04-18 12:40:02 PDT
Andreas:

Depending on which lands first, this or bug 746307 - I think one of us is going to get bitrotted.

-Mike
Comment 4 Richard Marti (:Paenglab) 2012-04-18 13:17:20 PDT
You was faster :)

I think it would be better if you are using -moz-margin-end instead of margin-right. Then it works also for rtl languages.

I played only with:

#file-space-used,
#remaining-file-space {
  -moz-margin-start: 0.5ch;
}

but wasn't satisfied with the aligning of the text with the square.

When you use:

#provider-space label {
  -moz-margin-end: 0.5ch;
  vertical-align: middle;
}

#file-space-used,
#remaining-file-space {
  vertical-align: middle;
}

then the square could be better aligned with the text.
Instead of:

#file-space-used,
#remaining-file-space {

you could also use:

#provider-space span {

and then remove in .space-swatch the vertical-align: middle;
Comment 5 Mike Conley (:mconley) 2012-04-18 13:32:39 PDT
Created attachment 616268 [details] [diff] [review]
Patch v1

Screenshots are next.
Comment 6 Mike Conley (:mconley) 2012-04-18 13:33:15 PDT
Created attachment 616269 [details]
Ubuntu
Comment 7 Mike Conley (:mconley) 2012-04-18 13:42:04 PDT
Created attachment 616271 [details]
OSX
Comment 8 Mike Conley (:mconley) 2012-04-18 13:45:22 PDT
Created attachment 616273 [details]
Windows 7
Comment 9 Mike Conley (:mconley) 2012-04-18 13:47:49 PDT
Created attachment 616274 [details]
Windows XP
Comment 10 Mike Conley (:mconley) 2012-04-18 13:49:06 PDT
Comment on attachment 616268 [details] [diff] [review]
Patch v1

Paenglab:

Awesome - thanks for the pointers!  Do I have the right idea, here?

-Mike
Comment 11 Richard Marti (:Paenglab) 2012-04-18 14:09:32 PDT
Comment on attachment 616268 [details] [diff] [review]
Patch v1

Yeah, this is what I thought. r+
Comment 12 Blake Winton (:bwinton) (:☕️) 2012-04-20 10:56:36 PDT
Comment on attachment 616268 [details] [diff] [review]
Patch v1

Based on the screenshots, it looks okay, but can someone tell me why we don't just add a space character to the end of cloudfileMgmt.usedSpace and cloudfileMgmt.unusedSpace in http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/messenger/cloudfile/management.dtd ?

Anyways, ui-r=me.

Thanks,
Blake.
Comment 13 Mike Conley (:mconley) 2012-04-20 11:01:34 PDT
(In reply to Blake Winton (:bwinton - Thunderbird UX) from comment #12)
> Comment on attachment 616268 [details] [diff] [review]
> Patch v1
> 
> Based on the screenshots, it looks okay, but can someone tell me why we
> don't just add a space character to the end of cloudfileMgmt.usedSpace and
> cloudfileMgmt.unusedSpace in
> http://mxr.mozilla.org/comm-central/source/mail/locales/en-US/chrome/
> messenger/cloudfile/management.dtd ?

Mainly because of string freeze, but also, because the spacing thing is more about style / appearance (CSS) rather than content (the .dtd in this case).

That's how I think about it, anyhow.

> 
> Anyways, ui-r=me.
> 

Thanks!  :D
Comment 14 Mike Conley (:mconley) 2012-04-20 11:48:27 PDT
Committed to comm-central as http://hg.mozilla.org/comm-central/rev/71654bcf7870
Comment 15 Mike Conley (:mconley) 2012-04-20 12:12:34 PDT
Committed to comm-aurora as http://hg.mozilla.org/releases/comm-aurora/rev/b166152a7dd4

Note You need to log in before you can comment on or make changes to this bug.