If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

media volume control remains active after closing Firefox

VERIFIED FIXED

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: lmandel, Assigned: cpeterson)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, blocking-fennec1.0 +)

Details

(Whiteboard: [mtd])

Once Firefox activates the media volume control on Android the media control remains even when closing Firefox. This prevents easy access to changing the volume of the phone.

Steps to reproduce:
1. Load a video in youtube.
2. Once the video starts playing change the volume with the physical volume buttons. The media volume control is displayed.
3. Close Firefox. The video stops playing. Change the volume using the physical volume buttons. The media volume is changed, not the expected ringer volume.

Expected results:
After Firefox closes using the volume buttons should control the ringer volume.

Actual results:
After Firefox closes using the volume buttons still control the media volume. Killing Firefox in the application settings generally reverts the volume control back to the ringer volume. Note that changing the page in Firefox to a page with no video and stopping the video ahead of closing Firefox seem to have no effect. 

Firefox 2012-04-17
Samsung Galaxy S II
Android 2.3.4
Are you quitting Firefox or putting it in the background? When quitting I get the media volume changing till the Firefox process ends.
Putting it in the background by clicking the home button on my phone. When I kill Firefox (through the settings->applications menu) the volume works as expected.

Updated

6 years ago
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → soft
Assignee: nobody → chrislord.net
blocking-fennec1.0: soft → +
Wrong Chris
Assignee: chrislord.net → cpeterson
(Assignee)

Comment 4

6 years ago
This looks like our application (or Flash) is not releasing "audio focus" when we are backgrounded.
(Assignee)

Comment 5

6 years ago
I believe gcp's fix for bug 717096 fixed this

* status-firefox15=fixed by gcp's fix
* status-firefox14=affected until gcp's fix lands on m-a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
status-firefox14: --- → affected
status-firefox15: --- → fixed
Depends on: 717096
Resolution: --- → FIXED
(Assignee)

Comment 6

6 years ago
status-firefox14=fixed by gcp's commit:
https://hg.mozilla.org/releases/mozilla-aurora/rev/a8a1d8dfba1d
status-firefox14: affected → fixed
Verified fixed on Nightly 15.0a1 (2012-05-20)
                  Aurora 14.0a2 (2012-05-20)
Status: RESOLVED → VERIFIED
status-firefox14: fixed → verified
status-firefox15: fixed → verified
See Also: → bug 1295398
You need to log in before you can comment on or make changes to this bug.