JS error (TypeError: b is null) results in unstyled Thank You lightbox; Automatic install doesn't start

VERIFIED FIXED in 6.5.2

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: potch)

Tracking

unspecified
6.5.2

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 616337 [details]
screenshot

steps to reproduce:
1. Purchase the app (without pre-auth) at https://marketplace-dev.allizom.org/en-US/app/basecamp-1/?src=search

observed behavior:
After purchase, we are shown an unstyled thank you message and automatic install doesn't start.

Timestamp: 4/18/12 4:19:41 PM
Error: TypeError: b is null
Source File: https://marketplace-dev-cdn.allizom.org/media/js/mkt/consumer-min.js?build=456e0eb
Line: 18
Priority: -- → P1
Assignee: nobody → thepotch
Duplicate of this bug: 747696
(Assignee)

Comment 2

6 years ago
Now we know what to look for in the future!

https://github.com/mozilla/zamboni/commit/f2a06cb
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 6.5.2
(Assignee)

Updated

6 years ago
Duplicate of this bug: 744999

Comment 4

6 years ago
Verified as fixed . No errors displayed and automatic install started.
Status: RESOLVED → VERIFIED

Comment 5

6 years ago
Created attachment 618325 [details]
Postfix Screenshot

Comment 6

6 years ago
Reproducible again using FF Nightly.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 7

6 years ago
The problem is now solved after installing the security update to Firefox nightly.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 8

6 years ago
Verified as fixed.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.