WP-reCAPTCHA plug-in is busted for blog.mozilla.com/nnethercote

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: njn, Assigned: jakem)

Tracking

Details

(Reporter)

Description

6 years ago
I have the WP-reCAPTCHA plug-in enabled for my Mozilla blog.  Some time recently it stopped working.  Instead of showing up at the bottom of a post, I now just get this message:

  Input error: Invalid referer

Is this something that is under server-ops's control?  Thanks.
(Assignee)

Comment 1

6 years ago
I suspect this may have broken due to the recent migration of blog.mozilla.com (now .org) to a new cluster in PHX1... this happened a week or so ago.

Adding Jason, he did a lot of work with WP plugins to make the migration happen. Any ideas?
(Assignee)

Comment 2

6 years ago
Actually, this may have been caused by the com->org name change. I suspect reCAPTCHA is expecting requests to come from the old name, blog.mozilla.com. That would explain the "invalid referer" message.

I don't know that we have generic site-wide reCAPTCHA API keys... so I followed the link and just made you new ones. This seems to be working again!
Assignee: server-ops → nmaul
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

6 years ago
I've confirmed that it's working again.  Thanks!
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.