StringFileInfo in installer files (*.exe *.dll) could need some fixup

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Problems:

- Empty fields. There is no need to include empty fields like Comments, 
LegalTrademarks, PrivateBuild, SpecialBuild.. It looks kind of uncool.

- use of "," instead of "." All the places I've seen people use "." and not ",".
See:
http://support.microsoft.com/support/kb/articles/Q107/9/92.asp
http://msdn.microsoft.com/library/psdk/winui/rc_3rxn.htm
etc...
(Reporter)

Comment 1

17 years ago
Created attachment 29678 [details] [diff] [review]
StringFileInfo update
(Reporter)

Updated

17 years ago
Summary: setup.exe StringFileInfo could need some fixup → StringFileInfo in installer files (*.exe *.dll) could need some fixup
(Reporter)

Comment 2

17 years ago
*** Bug 86851 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
Blocks: 50522
(Reporter)

Updated

17 years ago
Blocks: 86853

Comment 3

17 years ago
I should point out that I've seen this problem with other apps.  What happens is
that, if you edit the RC file using Microsoft Visual C++ 6.0, it will always add
those new fields to your version info.  That means that each time the RC file is
ever edited with the MS IDE, someone has to go in and manually remove those
lines again.
(Reporter)

Updated

17 years ago
No longer blocks: 50522

Comment 4

17 years ago
over to dprice.
Assignee: ssu → dprice
Product: Browser → Seamonkey
(Reporter)

Updated

12 years ago
QA Contact: bugzilla → general
Assignee: dprice → nobody
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.