If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser refuses to execute on account of xpcom.dll

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Matthew Schultz, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'm running 0.8.1 on Win98.  I'd check the build but the browser no longer 
seems to execute.  Here's the error it's giving me:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0177:60cf3e0d.
Registers:
EAX=00000000 CS=0177 EIP=60cf3e0d EFLGS=00010246
EBX=007b4030 SS=017f ESP=0068f5a4 EBP=0068f5cc
ECX=0068f6a8 DS=017f ESI=80000000 FS=3f87
EDX=81991900 ES=017f EDI=01d5acf0 GS=0000
Bytes at CS:EIP:
8b 08 ff 51 04 eb 1b 8b 45 08 50 8b 08 ff 51 08 
Stack dump:
00000000 80000000 01d59610 01d597b8 60d0b700 df71c6f0 11d2ec53 0000cabd 
74736564 007b4010 0068f5ec 60cf4166 00000000 01c73698 00000000 0068f6a8
Did you see the crash while you try to start mozilla ?

Can you try it again with a fresh profile ? 
(delete your "User50" directory. Attention you will lost all your profile data,
restart Mozilla and create a new profile)
(Reporter)

Comment 2

17 years ago
I'm running the talkback enabled zipfile version of Mozilla 0.8.1.  The folder, 
User50, does not exist.  I've also tried deleting the Netscape 4.x profile to 
see if that was interfering but Mozilla is still crashing with the same problem 
when it's executed.  
(Reporter)

Comment 3

17 years ago
I've also tried deleting the whole program from the computer and extracting it 
again and it nevertheless still crashes the same way when it's executed.

Comment 4

17 years ago
run "mozilla -profilemanager"

create a new profile and try.

profile data is in windows/application data/mozilla/profilename.

do you have any directx apps open?
Severity: blocker → critical
(Reporter)

Comment 5

17 years ago
I didn't have any directx apps open but I was able to find the profile and 
delete it.  I went to execute Mozilla after deleting the profile and it asked 
me if I want to convert the 4.x profile or create a new one.  I converted it 
and it works fine now.  Looks like you were correct in that something messed up 
the profile which caused the browser to crash whenever it was executed.  
Thanks for your fast answer !

I close this bug know as worksforme.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.