"Profile has incomplete Sync config. Not migrating." error is displayed in logs when starting Nightly without a sync profile set up

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: AdrianT, Unassigned)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 616543 [details]
logs

Nightly/14.0a1 (2012-04-19)
Device: HTC Desire Z/HTC Desire
OS: Android 2.3.3/Android 2.2.2

Steps to reproduce:
1. Create a new profile by clearing Nighlty data.
2. Make sure there is no sync account added on the device.
3. Connect the phone via the USB cable to the PC and open a log viewer.
4. Start Nightly.

Expected results:
There are no errors displayed.

Actual results:
"Profile has incomplete Sync config. Not migrating." error is displayed in the console

Note:
The issue is not seen using Nightly/14.0a1 2012-04-18
(Reporter)

Updated

6 years ago
Summary: "Profile has incomplete Sync config. Not migrating." error is displayed in console when starting Nightly without a sync profile set up → "Profile has incomplete Sync config. Not migrating." error is displayed in logs when starting Nightly without a sync profile set up
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/ProfileMigrator.java#436

It's not an error, it's log output. it means that during the migration check, you don't have Sync account to migrate.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.