Closed Bug 74699 Opened 22 years ago Closed 22 years ago

Attachment button should have a down-arrow (triangle)

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

x86
Windows NT
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED INVALID

People

(Reporter: Peter, Assigned: sspitzer)

References

Details

Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8.1), 2001-04-03, imap server

Attachment button should have a down-arrow (triangle) to indicate that there is
a submenu.

I know this seems like mixing button functions with menu functions, but that is
the way it has been implemented (I like it) and we must make it as descriptive
(i.e. userfriendly) as possible.
wouldn't it make the most sense to make this a menulist instead of a button?
Redesign

*** This bug has been marked as a duplicate of 73414 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
NO NO NO, the other bug is about a *Save All* feature! This bug is about the
attachment icon having a *DOWN ARROW*.

If you want a tracking bug for all attachments features and the new header, then
create a *META bug* for it and mark it dependant on all these DIFFERENT
attachment features bugs!

Keyser: STOP duping all bugs related to attachments to the "Save All" bug - they
are not dupes!
Keywords: mozilla0.9.1, ui
slow down man
OK.  I was kind of confused by ksosez dupping all the bugs to the "save all" bug
too....

Then I read the "save all" bug carefully.  I still think that this should not be
dupped to the save all bug.  But the save all bug says "I've implemented this
now. The patch is in 75691"  (carefully hidden not to be a link :) ).

And bug 75691 includes "I've re-written the message pane's attachment button /
menu popup to now be a tree widget listing the attachments. Here to, we now show
the document icon associated with each attachment."

So all these issues with the current button _are_ going away.  The button will
be no more.

All that said, Peter, you can just reopen a bug you file that gets resolved
incorrectly.  Just say why you're reopening in the description and reopen away...
Reopening to see if bug 75691 really adresses this issue. 

If it does, this bug is fixed. If it doesn't, then it is either still a valid
bug or it is a wontfix because bug 75691 fixed/solved the problem in a different
way ;)
Status: RESOLVED → UNCONFIRMED
Depends on: 75691
Resolution: DUPLICATE → ---
No longer depends on: 75691
My bad I am sorry PLairo I misread these bugs..My appologies I will be more
careful next time.
Marking New since (as peter says) this bug is either valid or will be fixed by
another bug. Addind that bug to the dependancy List. :)
Status: UNCONFIRMED → NEW
Depends on: 75691
Ever confirmed: true
The design of the attachment area has changed.  The attachments will be listed 
in a window (with a scroll bar if more attachments then fit the window).  This 
bug is now invalid due to spec change.  
Using build 2001-05-08 the attachment area is as stated in the spec description. 
 This should be resolved as invalid. 
invalid it is.
Status: NEW → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → INVALID
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.