Clicking on a filename in the attachment button should ask to "save" or "open" (in addition to the Save/Open submen)

VERIFIED INVALID

Status

--
enhancement
VERIFIED INVALID
18 years ago
13 years ago

People

(Reporter: Peter, Assigned: sspitzer)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.8.1), 2001-04-03, imap server

Clicking on a filename in the attachment button should ask to "save" or "open"
(in addition to the Save/Open submen)

There is more than one way to skin a cat ;)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

18 years ago
changing summary to "double-clicking" from "clicking" to more correctly reflect
what is meant.

There is little more annoying than thoughtlessly double-clicking an attachment
(and beginners do this a lot) and having a WHOLE SERIES of events occur
(download attachment, load application, load file into app, close app, curse at
the inconvenience, etc.) when one didn't necessarily whant that to happen.

Currently, as an "always saver" of attachments, I am barred from the convenience
of doubleclicking :(

A confirmation dialogue would be much better:

+-- What do you want to do with this attachment? --+
|                                                  |
|        < save to disk >    < open >              |
|                                                  |
+--------------------------------------------------+
Keywords: mozilla0.9.2, nsCatFood, ui
Summary: Clicking on a filename in the attachment button should ask to "save" or "open" (in addition to the Save/Open submen) → Double-clicking on a filename in the attachment button should ask to "save" or "open" (in addition to the Save/Open submen)
(Reporter)

Comment 2

18 years ago
changing summary back to "clicking" and marking "invalid" since this bug was
referring to the old attachment button UI.

I just hate having my bugs being "invalid" - it's soo degrading ;)
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Summary: Double-clicking on a filename in the attachment button should ask to "save" or "open" (in addition to the Save/Open submen) → Clicking on a filename in the attachment button should ask to "save" or "open" (in addition to the Save/Open submen)

Comment 3

18 years ago
Closing this bug.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.