[Apps] partners page implementation

VERIFIED FIXED in 2.2

Status

www.mozilla.org
General
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: malexis, Assigned: sgarrity)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
PSDs attached to design bug#744046 

Here are all the video conversions. 


http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Audiovroom.webm

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Mixmatchmusic.webm

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Teambox.webm

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_kicksend%202.webm

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Teambox-360p-mp4.mp4

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_kicksend-360p-mp4.mp4

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Mixmatchmusic-360p-mp4.mp4

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Audiovroom-360p-mp4.mp4

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_kicksend-360p-mp4.theora.ogv

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Teambox-360p-mp4.theora.ogv

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Mixmatchmusic-360p-mp4.theora.ogv

http://videos-cdn.mozilla.net/serv/drafts/Moz_Market_Audiovroom.theora.ogv
(Reporter)

Updated

6 years ago
Assignee: nobody → steven
(Assignee)

Comment 1

6 years ago
What will the URL for this page be?
(Assignee)

Comment 2

6 years ago
Mike, a quick update on this. We've got the page mostly implemented locally. Need to build out the video playlist switcher and some other polish. Will update shortly.
(Assignee)

Comment 3

6 years ago
Also, the mockup shows next/prev controls next to the video thumbnails, but according to this bug, there are only four videos. I'd suggest we just show all four thumbnails.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 744047
(Reporter)

Comment 5

6 years ago
Thanks Steven. I agree showing all four thumbnails makes the most sense.

Regarding URL, Dan can you confirm what it should be?

Something like mozilla.org/apps/partners ?
(Assignee)

Comment 6

6 years ago
This page is now setup in dev: https://www-dev.allizom.org/en-US/apps/partners/

Raymond, everything should be working except that videos don't stop playing with you click another video thumbnail (so you can have all four playing at once!). Fix for that is pending.
looks good. Will wait till video fix is in to verify
(Assignee)

Comment 8

6 years ago
Ok, the video fix has been pushed to dev. Ready for testing at  https://www-dev.allizom.org/en-US/apps/partners/

Raymond, please be sure to test in IE, as the videos fall-back to the Flash player. Thanks.
(Assignee)

Updated

6 years ago
Keywords: qawanted
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
qa-verified-trunk  https://www-dev.allizom.org/en-US/apps/partners/ video works now only that there is a lag in IE 7 &8
Keywords: qawanted
(Assignee)

Comment 10

6 years ago
The lag that Raymond has noted in IE is a known issues. We're using our old Flash player for videos in IE and it's not scriptable, so we have some hacks to make the tab switching work in IE for videos.

In the longer term, we should probably switch to a more modern player, like JWplayer.
(Assignee)

Comment 11

6 years ago
This is in master and will go out today with another push.
(Assignee)

Comment 12

6 years ago
This page isn't linked to from anywhere (yet?) - should it be?
(Reporter)

Comment 13

6 years ago
(In reply to Steven Garrity from comment #12)
> This page isn't linked to from anywhere (yet?) - should it be?

I don't believe so. Dan, can you confirm? 

We could link to it from the apps marketplace homepage.
(Assignee)

Comment 14

6 years ago
We're live!

 https://www.mozilla.org/en-US/apps/partners/
verified fixed  https://www.mozilla.org/en-US/apps/partners/
Status: RESOLVED → VERIFIED

Comment 16

6 years ago
Hi Guys - just realised I never said thanks for this, so... thanks :) This page looks great.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.