[Marketplace] Disable install buttons and add disclaimers for non-Firefox 15 user agents

RESOLVED FIXED in 2012-06-14

Status

Marketplace
Consumer Pages
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cvan, Assigned: cvan)

Tracking

2012-06-14
Points:
---

Details

(Assignee)

Description

5 years ago
Since native app installation works only with Nightly (Firefox 13+), we need to add a warning message and hide install/purchases buttons for all other users.

CC'ing fligtar for copy
(Assignee)

Updated

5 years ago
Assignee: nobody → cvan

Updated

5 years ago
Assignee: cvan → nobody

Updated

5 years ago
Assignee: nobody → cvan
(Assignee)

Updated

5 years ago
Assignee: cvan → nobody
(Assignee)

Updated

5 years ago
Assignee: nobody → cvan
(Assignee)

Comment 1

5 years ago
Link to https://wiki.mozilla.org/Marketplace/Mozillian_Preview
Summary: [Marketplace] Disable install buttons and add disclaimers for non-Firefox 13 user agents → [Marketplace] Disable install buttons and add disclaimers for non-Firefox 15 user agents

Comment 2

5 years ago
https://github.com/mozilla/zamboni/commit/8cef5ce
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Assignee: cvan → thepotch

Comment 3

5 years ago
The buttons are still enabled on my Android Stock browser.

user agent is: Mozilla/5.0 (Linux; U; Android 4.0.1; en-us; Galaxy Nexus Build/ITL41F) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
Assignee: thepotch → cvan
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 4

5 years ago
https://github.com/mozilla/zamboni/commit/087d8d2 
https://github.com/mozilla/zamboni/commit/aa8d9ee
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 5

5 years ago
Buttons are still enabled on mobile device . Build identifier : Mozilla/5.0(Android;Mobile; rv:10.0.4)Gecko/10.0.4 Firefox/1-.0.4 Fennec 10.0.4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

5 years ago
Duplicate of this bug: 755397
(Assignee)

Comment 7

5 years ago
https://github.com/mozilla/zamboni/commit/4eb4604
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Assignee: cvan → nobody
Component: Public Pages → Consumer Pages
Product: addons.mozilla.org → Marketplace
QA Contact: web-ui → consumer-pages
Target Milestone: 6.5.2 → 2012-06-14
Version: unspecified → 1.0
(Assignee)

Comment 8

5 years ago
https://github.com/mozilla/zamboni/commit/02f0973
Assignee: nobody → cvan
You need to log in before you can comment on or make changes to this bug.