Prettify the payment modal

VERIFIED FIXED in 6.5.2

Status

addons.mozilla.org Graveyard
Public Pages
P2
normal
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: spasovski)

Tracking

unspecified
6.5.2

Details

(URL)

(Reporter)

Description

6 years ago
steps to reproduce:
1. Load https://marketplace-dev.allizom.org/en-US/app/backpack/?src=search
2. Click on the purchase button

observed behavior:
Issues-

* Currency selector looks like a clickable button.
* The payment section should look like http://cl.ly/1R0i3z1B3O1T1F00313J
* Put the 'x' link to close the icon outside of the box.
(Reporter)

Updated

6 years ago
Assignee: nobody → dspasovski
(Assignee)

Comment 1

6 years ago
done: https://github.com/mozilla/zamboni/commit/9b69d42
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
(In reply to krupa raj 82[:krupa] from comment #0)
 
> * Currency selector looks like a clickable button.
> * The payment section should look like http://cl.ly/1R0i3z1B3O1T1F00313J
> * Put the 'x' link to close the icon outside of the box.

None of these issues have been addressed.

Also, The lightbox contracts after a few seconds. See http://screencast.com/t/e7rmIQ22wO6
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

6 years ago
The lightbox contraction is expected since JS is resizing the modal to fit its contents. If this is a deal-breaker we can talk about it. It should ensure we never get scrollbars again which means the X-close can stay as is.

done: https://github.com/mozilla/zamboni/commit/42bd6b9
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

6 years ago
I checked with fligtar and he wants the lightbox contraction to be fixed. It has a very jarring user experience.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 5

6 years ago
Also, we need to change the copy- "Make a one time payment using your credit card." to "Make a one time payment using your PayPal account".
(Assignee)

Comment 6

6 years ago
done: https://github.com/mozilla/zamboni/commit/34d6f50
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

6 years ago
This looks way better now. Although the currency selector could still use some help.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.