Last Comment Bug 747163 - TelemetryHistogramType returns failure for HISTOGRAM_FLAG
: TelemetryHistogramType returns failure for HISTOGRAM_FLAG
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Telemetry (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla15
Assigned To: Graeme McCutcheon [:graememcc]
:
: Georg Fritzsche [:gfritzsche]
Mentors:
Depends on:
Blocks: 724513
  Show dependency treegraph
 
Reported: 2012-04-19 13:55 PDT by Graeme McCutcheon [:graememcc]
Modified: 2012-04-27 06:53 PDT (History)
2 users (show)
graeme.mccutcheon: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (679 bytes, patch)
2012-04-19 13:56 PDT, Graeme McCutcheon [:graememcc]
taras.mozilla: review+
Details | Diff | Splinter Review
With tests (2.98 KB, patch)
2012-04-20 09:07 PDT, Graeme McCutcheon [:graememcc]
taras.mozilla: review+
Details | Diff | Splinter Review

Description Graeme McCutcheon [:graememcc] 2012-04-19 13:55:14 PDT

    
Comment 1 Graeme McCutcheon [:graememcc] 2012-04-19 13:56:49 PDT
Created attachment 616736 [details] [diff] [review]
v1

...and here's why!
Comment 2 (dormant account) 2012-04-19 22:49:06 PDT
Comment on attachment 616736 [details] [diff] [review]
v1

This needs Telemetry.histogramFrom testcase added for a flag histogram. I'm guessing you stumbled upon this because it caused an error on startup?
Comment 3 Graeme McCutcheon [:graememcc] 2012-04-20 09:07:55 PDT
Created attachment 616988 [details] [diff] [review]
With tests

> I'm guessing you stumbled upon this because it caused an error on startup?

I added a telemetry flag in bug 724513, which had "cache" in the description, which caused it to get picked up by gatherStartupInfo in TelemetryPing.js, so test_TelemetryPing started failing in the histogramFrom/TelemetryHistogramType call.

I've added a test to exercise histogramFrom for all types, however it uncovered bug 747379. Bugs all the way down!
Comment 4 (dormant account) 2012-04-20 09:52:21 PDT
Comment on attachment 616988 [details] [diff] [review]
With tests

Graeme, I only see additional implicit {} moving around in this patch, are you sure that's the right patch?
Comment 5 (dormant account) 2012-04-20 09:55:01 PDT
Comment on attachment 616988 [details] [diff] [review]
With tests

nm. r+ with pointless {} changes undone.
Comment 6 Graeme McCutcheon [:graememcc] 2012-04-26 01:56:47 PDT
Not sure how those brace changes got in there. I probably thought I'd added them when debugging the test failure that became 747379.

Anyway, https://hg.mozilla.org/integration/mozilla-inbound/rev/304cd5d5124b
Comment 7 Ed Morley [:emorley] 2012-04-27 06:53:21 PDT
https://hg.mozilla.org/mozilla-central/rev/7ce462a9693d

Note You need to log in before you can comment on or make changes to this bug.