Closed Bug 747354 Opened 10 years ago Closed 10 years ago

Download is displayed as completed if the Wifi connection is lost

Categories

(Firefox for Android Graveyard :: General, defect)

14 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox14 fixed, blocking-fennec1.0 soft, fennec15+)

RESOLVED FIXED
Tracking Status
firefox14 --- fixed
blocking-fennec1.0 --- soft
fennec 15+ ---

People

(Reporter: AdrianT, Assigned: wesj)

References

Details

Attachments

(2 files)

Attached file logs
Nightly/14.0a1 (2012-04-20)
Device: HTC Desire/ HTC Desire Z
OS: Android 2.2.2/Android 2.3

Steps to reproduce:
1. Start the download of a large file - like the latest Nightly build.
2. Open the Download Manager.
3. While downloading the file disconnect/turn off the Wifi connection.
4. Wait a few seconds and re-enable the connection.
5. Open the Download Manager.

Expected results:
When the Wifi connection is lost the download is paused and is resumed after the Wifi is re-enabled.

Actual results:
A notification that the file download has been completed is displayed in the Notification Bar. In the Download Manager the file is displayed as being downloaded.
Issue is only reproducible if the Download Manager is opened. If the Download Manager is not opened there is an error pop-up displayed that the file is no longer accessible.

Note:
 - The issue is not reproducible on the Android stock Browser or Dolphin HD where the download is paused.
 - The issue could not be reproduced on Galaxy S2(Android 2.3.4) where both with and without the Download Manager opened the error pop-up is displayed.
 - I am using only Wifi and do not have a SIM in the phone in order for the device to try and connect to the 3G network
I think maybe the simplest fix is to adjust our query slightly. We currently check for downloads that are NOT in state

DOWNLOAD_NOTSTARTED, DOWNLOAD_DOWNLOADING, DOWNLOAD_PAUSED, DOWNLOAD_QUEUED, DOWNLOAD_SCANNING

I think we could modify that to just return only downloads that are in state DOWNLOAD_FINISHED. Need to dig through the source to make sure we don't set that for dirty/cancelled/etc downloads.
blocking-fennec1.0: --- → ?
Since we have no download mgr controls to pause/resume/cancel (bug 741655), looking for DOWNLOAD_FINISHED seems like a good short term fix.
tracking-fennec: --- → 15+
blocking-fennec1.0: ? → soft
Attached patch PatchSplinter Review
Assignee: nobody → wjohnston
Attachment #619800 - Flags: review?(mark.finkle)
Attachment #619800 - Flags: review?(mark.finkle) → review+
Comment on attachment 619800 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): 695178 - Download Manager for native
User impact if declined: Download manager behavior can be confusing and unpredictable
Testing completed (on m-c, etc.): Landed on mc today (May 2)
Risk to taking this patch (and alternatives if risky): Low risk. Mobile only. Only JS in the Download Manager
String changes made by this patch: None.
Attachment #619800 - Flags: approval-mozilla-aurora?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Attachment #619800 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Marking as fixed in 14.
Depends on: 753710
There are still issues with interrupting downloads when the Wifi connection is lost - please see 753710. The bug is reproducible on both Nightly 15.0a1 2012-05-22 and Aurora 14.0a2 2012-05-21 on HTC Desire running Android 2.2.2.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.