Attachment flag not shown in Mail Window Frontend

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Emanuele Bellini, Unassigned)

Tracking

11 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

I received an e-mail message with an attachment.


Actual results:

The clip of the attachment hasn't been shown in the main window.


Expected results:

I should know if a message contains an attachment!
(Reporter)

Updated

6 years ago
Severity: normal → major
Summary: Attachment not shown in Mail Window Frontend → Attachment flag not shown in Mail Window Frontend
(Reporter)

Updated

6 years ago
Severity: major → normal
(Reporter)

Comment 1

6 years ago
The clip didn't appear at first, now that I opened the messages I've got it. Yes, because I had this issue with two e-mail messages. Anyway, this isn't the first time I'm going to open them, the first time I can't remember there was an attachment in the first one, so it could be Thunderbird didn't recognize it at all.

Comment 2

6 years ago
(In reply to Emanuele Bellini from comment #1)
Is this the same complaint in bug 747438 ?

Comment 3

6 years ago
We base the initial setting of the hasAttachment flag based on the top level mime content type of the message, i.e., the content-type header. If it's not multipart/mixed, we don't know that the message has an attachment.  When we display the message, we run the whole message through our mime parser and sometimes detect attachments in messages that weren't indicated by the top level mime content type. So, what's the content type of your message? View | message source should let you see the content type header.
(Reporter)

Comment 4

6 years ago
@Hashem: no, the two are different ones. In this one I'm talking about an attachment which isn't recognized, in the other I have an attachment which is recognized but it isn't handled as such.
@David: you're right, it is multipart/alternative (it was sent with Apple Mail). I looked for that on the Internet, I think it isn't a standard e-mail message as long as it should've been /mixed and then I can close this bug report. Is it OK?

Comment 5

6 years ago
Emanuele, yes, thx, you can close the bug report. Apple Mail shouldn't be including attachments in multipart/alternative messages.
(Reporter)

Comment 6

6 years ago
Thank you David, sorry, I assumed the messages to be properly formed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.