cdw.com - Javascript Pop-up Menus Don't Appear....

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P2
minor
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: dan.m, Unassigned)

Tracking

Details

(Whiteboard: [aok[, URL)

(Reporter)

Description

17 years ago
...not sure if this is a result of the Event Handler issue that I read about in
the .8.1 user notes, but when you visit CDW's site, the home page has a
javascript navigation menu for each of its major product categories (hardware,
software, networking, etc.). Typically, when you roll your mouse over said
items, a menu will drop down which lists all the relevant sub-categories. Works
in IE 5 for Mac but does not seem to work in Mozilla (2001040309). If you click
the menus, you are taken a static HTML page with the sub-cats, so I've presume
this to be minor, but still worthy of reporting to you guys.
The page uses SetMenu to show the menus:

	function setMenu(menuHeaderID,menuID)
	{
		var top = 0;
		var left = 0;
		var currentEle;
		
		if(document.all)
		{
                     // do things
                }
        }

Since document.all is only supported by IE, this does not work in Mozilla or
Netscape.

Over to evangelism.  How nice of the site to go out of its way not to work with us.
Assignee: rogerl → evangelism
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Evangelism
Ever confirmed: true
OS: Mac System 9.x → All
QA Contact: pschwartau → zach
Hardware: Macintosh → All

Comment 2

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Updated

17 years ago
Priority: -- → P2

Updated

17 years ago
Summary: Javascript Pop-up Menus Don't Appear.... → cdw.com - Javascript Pop-up Menus Don't Appear....

Comment 3

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 4

16 years ago
http://www.cdw.com//global/gui/javascript/menu.js

Comment 5

16 years ago
*** Bug 109336 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 113492

Updated

16 years ago
Whiteboard: [aok[

Updated

16 years ago
No longer blocks: 113492

Comment 6

16 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr

Comment 7

15 years ago
1 year later, cdw.com still only supports document.all

Possible contact addresses are e-account@web.cdw.com and feedback@web.cdw.com

Comment 8

15 years ago
if it's any consolation, their Shopping Cart works properly with Mozilla.  My
company is a corporate client with them and they fixed it "for me" about a year
ago.  And, I don't think we're prevented from reaching any areas of the site by
the missing expanding-menus.

Comment 9

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Comment 10

15 years ago
same problem with: www.swissre.com

Comment 11

14 years ago
I tried cdw.com with Internet Explorer and Mozilla Firebird (Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031203 Firebird/0.7+) and
both are working in the same way with the menu.
Probably it was changed some time ago.
I think this bug should be changed as fixed now!

Comment 12

14 years ago
I concur.  I think they responded and use standard coding now.
BUGs 199641 and 230117 are the same.

Comment 14

14 years ago
bug 199641 (no pop-up menus at kato-eng.com)
bug 230117 (no pop-up menus at bpi.com.ph) 
certainly sound similar to this cdw.com bug but they might have different
root-causes.  

If they are the same, though, then they need to be DUPE'd to this bug and this
bug needs to become more code-specific and less site-specific (since it'll have
3 examples).  Sorry, but I'm not the one to make that call.

In any case, the pop-up menus at cdw.com definitely work now (Firefox 0.8 on WinXP)

Comment 15

12 years ago
Closing bug.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.