Last Comment Bug 747545 - Uevent Poller causes compile error when built debug due to ScopedClose member change
: Uevent Poller causes compile error when built debug due to ScopedClose member...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla14
Assigned To: Kyle Machulis [:kmachulis] [:qdot]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 14:47 PDT by Kyle Machulis [:kmachulis] [:qdot]
Modified: 2012-04-21 23:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Change .mFd to .get() in Uevent poller assert (433 bytes, patch)
2012-04-20 14:59 PDT, Kyle Machulis [:kmachulis] [:qdot]
mwu.code: review+
Details | Diff | Splinter Review

Description Kyle Machulis [:kmachulis] [:qdot] 2012-04-20 14:47:56 PDT
There's an assert in hal/gonk/UeventPoller.cpp:143 (landed in bug 742226) that uses a ScopedClose with .mFd member instead of .get(). This causes gecko to not compile in debug mode. 

This didn't burn any trees because we only compile release B2g on try currently. :( :( :(
Comment 1 Kyle Machulis [:kmachulis] [:qdot] 2012-04-20 14:59:54 PDT
Created attachment 617109 [details] [diff] [review]
Change .mFd to .get() in Uevent poller assert
Comment 2 Kyle Machulis [:kmachulis] [:qdot] 2012-04-20 18:44:35 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/85a3c4509d28
Comment 3 Phil Ringnalda (:philor) 2012-04-21 23:51:53 PDT
https://hg.mozilla.org/mozilla-central/rev/85a3c4509d28

Note You need to log in before you can comment on or make changes to this bug.