Redirect press center URLs to the new press center blog

VERIFIED FIXED in 2.9

Status

www.mozilla.org
General
P1
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: craigcook, Assigned: craigcook)

Tracking

unspecified
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: r=104779,104797 b=trunk, URL)

(Assignee)

Description

6 years ago
We've moved the Mozilla Press Center to a WordPress-powered blog at blog.mozilla.org/press and migrated over the essential content. Managing the press center via WordPress will let the PR team easily update content without needing a webdev to change the code and IT to push it.

We need to set up some rewrite rules to send press center URLs to their new locations on the blog. We can begin weeding out and updating links, but a few redirect rules should catch them. I'll edit .htaccess and update this bug shortly with a commit number.
(Assignee)

Comment 1

6 years ago
.htaccess updated in r104597
Whiteboard: r=104597 b=trunk
Keywords: qawanted
Thanks Craig! When do you want this pushed? Immediately? If so, once QA verifies I will push.
Target Milestone: --- → 2.2
(Assignee)

Comment 3

6 years ago
(In reply to James Long (:jlongster) from comment #2)
> Thanks Craig! When do you want this pushed? Immediately? If so, once QA
> verifies I will push.

You can push at your earliest convenience. So, yeah, I guess "immediately" but it's not super-urgent. Today or tomorrow would be great.
Sounds great. Marking resolved and will push tomorrow if passed QA.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
qa-verified-trunk  all links redirect to blog.mozilla.org/press
pushed to production r104731
Keywords: qawanted
Whiteboard: r=104597 b=trunk
(Assignee)

Comment 7

6 years ago
Doh, looks like I missed redirecting the main press center page. Updated htaccess in r104742.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

6 years ago
Whiteboard: r=104742 b=trunk → r=104742,104743 b=trunk
(Assignee)

Updated

6 years ago
Whiteboard: r=104742,104743 b=trunk → r=104742,104743,104779 b=trunk
(Assignee)

Updated

6 years ago
Whiteboard: r=104742,104743,104779 b=trunk → r=104779,104797 b=trunk
Looks like the redirects have been removed except http://www.mozilla.org/en-US/press/media

Updated

6 years ago
Status: RESOLVED → REOPENED
OS: Mac OS X → All
Hardware: x86 → All
Resolution: FIXED → ---

Updated

6 years ago
Target Milestone: 2.2 → 2.6

Updated

6 years ago
Assignee: nobody → craigcook.bugz
Priority: -- → P1

Updated

6 years ago
Target Milestone: 2.6 → 2.8
Flags: in-testsuite?
Need to make this a high priority since it's blocking launch of the updated press center.

craig, do we need to loop in jakem or anyone else to help debug?
Severity: normal → major
Target Milestone: 2.8 → 2.9
This was just never pushed to production.

Done as of r106325.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Restoring unintended removal of in-testsuite flag.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.