Last Comment Bug 747593 - Attachment File Name is Hard to Read with Aero and a Dark Desktop Background
: Attachment File Name is Hard to Read with Aero and a Dark Desktop Background
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Message Reader UI (show other bugs)
: 11 Branch
: x86_64 Windows 7
: -- normal (vote)
: Thunderbird 15.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 18:49 PDT by mozilla
Modified: 2012-04-24 16:25 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
attachment.png (7.41 KB, image/png)
2012-04-20 18:49 PDT, mozilla
no flags Details
Patch (1.83 KB, patch)
2012-04-21 04:52 PDT, Richard Marti (:Paenglab)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Review
Comparison before and after patch (53.52 KB, image/png)
2012-04-23 14:40 PDT, Richard Marti (:Paenglab)
no flags Details
Patch for aurora and beta (771 bytes, patch)
2012-04-23 14:43 PDT, Richard Marti (:Paenglab)
no flags Details | Diff | Review

Description mozilla 2012-04-20 18:49:42 PDT
Created attachment 617174 [details]
attachment.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Under Windows, enable Aero and set the desktop background to black.  Open an email with an attachment in Thunderbird 11.0.1 running the default theme.


Actual results:

I couldn't read the attachment's file name because the text was the same color as the background.


Expected results:

I should have been able to read the text because the text should have been a different color than the background.
Comment 1 Richard Marti (:Paenglab) 2012-04-21 04:52:05 PDT
Created attachment 617208 [details] [diff] [review]
Patch

This patch removes the now needless -moz-win-borderless-glass appearance for the messageWindow and gives the attachmentBar the same color as in messengerWindow. Also styled the status-bar like in messengerWindow.
Comment 2 Richard Marti (:Paenglab) 2012-04-23 14:40:51 PDT
Created attachment 617648 [details]
Comparison before and after patch

This screenshot shows the attachment bars of standalone window and main window. On top before the patch, below with patch. The only difference is the color of the bar. With patch both have the same color, without patch not.
Comment 3 Richard Marti (:Paenglab) 2012-04-23 14:43:35 PDT
Created attachment 617649 [details] [diff] [review]
Patch for aurora and beta

In case this patch should land on aurora or beta I've added a version without the status-bar color change for Australis.
Comment 4 Blake Winton (:bwinton) (:☕️) 2012-04-24 07:43:31 PDT
Comment on attachment 617208 [details] [diff] [review]
Patch

I don't know if this is the same as the original reporter's problem, but it certainly does what it says in the patch description, so ui-r=me.

And the code seems fine, too, so r=me as well.

Thanks,
Blake.
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-04-24 16:25:13 PDT
http://hg.mozilla.org/comm-central/rev/2f9a803068eb

Note You need to log in before you can comment on or make changes to this bug.