One Blog entry constantly showing up at the top of the feed

RESOLVED FIXED

Status

Websites
planet.mozilla.org
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Caspy7, Assigned: reed)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
The following blog entry is constantly showing up for me at the top of PMO feed:
http://jeditoolkit.com/2012/04/26/code-logic-not-mechanics.html
Looks like its future date (Thursday, 26 April 2012) is probably the culprit.
It's understandable to allow times which are future to the local machine because of timezones.  But it doesn't make sense to allow times which are much beyond 24 hours.  Why don't we throw in a few hours of fudge factor for incorrect clocks and force anything over 30 hours in the future to the local machine's date (while keeping the original wall clock time)?
(Assignee)

Updated

6 years ago
Duplicate of this bug: 747653
(Assignee)

Comment 2

6 years ago
Best fix I have right now is to remove the blog feed. r104613

I'll re-add it once the 26th rolls around. Also, I'll see if there's some way to get Planet to determine the valid date rather than relying on the blog to do so.
Assignee: nobody → reed
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

6 years ago
Found a fix!

http://intertwingly.net/code/venus/docs/normalization.html#overrides

Going to set 'future_dates = ignore_date' on all posts.
(Assignee)

Comment 4

6 years ago
ok, added new config option in r104615... readded blog in r104616. I may need to get IT to remove the cached copy before it works, but let's see.
You need to log in before you can comment on or make changes to this bug.