The default bug view has changed. See this FAQ.

Only create .plist file after icon has been downloaded

VERIFIED FIXED in Firefox 14

Status

Firefox Graveyard
Web Apps
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

Trunk
Firefox 14
All
Mac OS X
Dependency tree / graph
Bug Flags:
in-moztrap +

Details

(Whiteboard: [marketplace-beta=])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
When the .plist file is created, Finder caches the information about the app, and depending on the timing, if the .icns icon file has not been created yet, the app will get the generic app icon instead of the proper one, and Finder won't refresh the info (I think if you kill it or restart the computer it might work).

To avoid this we need to create the .plist file only after the icon has been downloaded and converted to the right format.

(There's 1 or 2 bugs already filed about icons not always working correctly on Mac which are likely duplicates of this.)
(Assignee)

Comment 1

5 years ago
Created attachment 617269 [details] [diff] [review]
Patch

Dan, could you reliably reproduce this problem? Can you test to see if this patch fixes it? It should implement the simpler solution that we discussed.
(Assignee)

Updated

5 years ago
Attachment #617269 - Flags: feedback?(dwalkowski)

Updated

5 years ago
Blocks: 731054
(Assignee)

Comment 2

5 years ago
Comment on attachment 617269 [details] [diff] [review]
Patch

Even if this patch doesn't fix the problem entirely (I believe it will, but I cannot reproduce the problem), it's a correct patch anyway that will be necessary, so I'm gonna go ahead and request review.

Markus, I just took the plist creation out of _createConfigFiles and into its own function. getIconForApp already had a callback parameter for when it finishes processing the icon, but it was unused. I also added some code to make sure it gets called even if downloading the icon fails.
Attachment #617269 - Flags: review?(mstange)
Attachment #617269 - Flags: review?(mstange) → review+
(Assignee)

Comment 3

5 years ago
Leaving open to see if there's anything more that will be needed to fix the original bug.

https://hg.mozilla.org/integration/mozilla-inbound/rev/3dd842015565
Whiteboard: [leave open]
https://hg.mozilla.org/mozilla-central/rev/3dd842015565
Target Milestone: --- → Firefox 14

Updated

5 years ago
Duplicate of this bug: 747414
(Assignee)

Updated

5 years ago
Blocks: 745999

Updated

5 years ago
Whiteboard: [leave open] → [leave open] [marketplace-beta-]
Whiteboard: [leave open] [marketplace-beta-] → [leave open] [marketplace-beta=]
(Assignee)

Comment 6

5 years ago
The rest of the necessary work to fix the original bug (osx caching the incorrect icon) was covered by bug 748199
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [leave open] [marketplace-beta=] → [marketplace-beta=]
(Assignee)

Updated

5 years ago
Attachment #617269 - Flags: feedback?(dwalkowski)
(Assignee)

Comment 7

5 years ago
For Jason: the two dependents bugs here are most likely fixed by this change + the change that just landed from bug 748199.
Blocks: 732612
Keywords: qawanted
This works on OS X 10.7. Does not work at all on OS X 10.5. Requesting to reopen.
Keywords: qawanted
On OS X 10.6 - Does not fully work either. If I have the applications folder open, and I install an application, the icon may not appear. If close finder, reopen the applications directory, then I will see the icon.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 10

5 years ago
(In reply to Jason Smith [:jsmith] from comment #9)
> On OS X 10.6 - Does not fully work either. If I have the applications folder
> open, and I install an application, the icon may not appear. If close
> finder, reopen the applications directory, then I will see the icon.

Was this with a hourly mozilla-central build from this afternoon?
(In reply to Felipe Gomes (:felipe) from comment #10)
> (In reply to Jason Smith [:jsmith] from comment #9)
> > On OS X 10.6 - Does not fully work either. If I have the applications folder
> > open, and I install an application, the icon may not appear. If close
> > finder, reopen the applications directory, then I will see the icon.
> 
> Was this with a hourly mozilla-central build from this afternoon?

It was with today's nightly build (4/26/2012) on OS X 10.5/10.6/10.7. Ah I see the other patch will land tomorrow in mozilla in-bound. I'll move this back to resolved fixed and retest this tomorrow.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

5 years ago
Actually the relevant patches landed in mozilla-central today, so they will be in Nightly's tomorrow (the ones marked as 2012/04/27)
Re-tested:

- OS X 10.5 - Fail (No icon shows up when installing an app - see bug 745999)
- OS X 10.6 - Pass
- OS X 10.7 - Pass

Should we reopen this bug for the issue in OS X 10.5? Or is the issue with OS X 10.5 separate from this bug, so we should track it in bug 745999?
(Assignee)

Comment 14

5 years ago
this bug was for a very specific issue, so let's track that in bug 745999
(In reply to Felipe Gomes (:felipe) from comment #14)
> this bug was for a very specific issue, so let's track that in bug 745999

Sounds good. Marking this as verified. Followup work for the specific issue in bug 745999 will be tracked in that bug.
Status: RESOLVED → VERIFIED

Updated

5 years ago
No longer blocks: 731054

Updated

5 years ago
Flags: in-moztrap?(jsmith)

Updated

5 years ago
Flags: in-moztrap?(jsmith) → in-moztrap+

Updated

5 years ago
QA Contact: jsmith
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.