Status

Tracking
Metro Operations
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: bbondy, Unassigned)

Tracking

({feature, meta})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=epic)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 617342 [details]
Start screen 1

This task is to support the Windows 8 start screen
Please see the attached screenshots.

- The new start screen should have the following sections: Top sites, bookmarks, recent history, and downloads
- They should appear as a group of tiles/boxes for each of those sections
- Initially only part of that screen should be visible and the user can swipe from right to left to start revealing the rest of the content.. (Similar to how the windows 8 start screen).
(Reporter)

Comment 1

6 years ago
Created attachment 617343 [details]
Start screen 2
(Reporter)

Updated

6 years ago
Blocks: 747790
Depends on: 634139

Updated

6 years ago
Component: General → General
Product: Fennec → Firefox
Assignee: nobody → jonathan
Status: NEW → ASSIGNED
This will be implemented as an "unfiltered" state of the autocomplete screen in bug 747790. This state will be automatically be shown when:

- There are no results to show in the autocomplete screen because the user hit backspace enough to clear out the bar.
- When the user is on about:start (which, under-the-hood, is an alias of about:blank).
Scaffolding is now in place.  Now, I've just got to implement the view code for the different start screen sections to fill the grids in with data.

http://hg.mozilla.org/projects/elm/rev/1c2eaa739c94
Making bookmarks be updated when things change:
http://hg.mozilla.org/projects/elm/rev/bdadd1251588

Updated

6 years ago
Blocks: 785037
Assignee: hello → nobody
Keywords: meta
Whiteboard: [metro-beta]

Updated

6 years ago
Blocks: 784042

Updated

6 years ago
Summary: Support new start screen with top sites, bookmarks, recent history, downloads → [Tracking] Support new start screen with top sites, bookmarks, recent history, downloads

Updated

6 years ago
Depends on: 793502

Updated

6 years ago
No longer blocks: 747790, 784042, 785037
Depends on: 747790, 784042, 785037

Updated

6 years ago
Depends on: 793515

Updated

6 years ago
Status: ASSIGNED → NEW

Updated

6 years ago
Depends on: 794028

Updated

6 years ago
Depends on: 794030

Updated

6 years ago
Depends on: 794033

Updated

6 years ago
Blocks: 782867

Updated

6 years ago
Depends on: 792901

Updated

6 years ago
Depends on: 794064

Updated

6 years ago
Depends on: 794135

Updated

6 years ago
Blocks: 794227

Updated

6 years ago
No longer blocks: 794227

Updated

6 years ago
Depends on: 797180

Updated

6 years ago
Component: General → General
Product: Firefox → Firefox for Metro

Updated

6 years ago
Keywords: feature
Whiteboard: [metro-beta] → [metro-beta][metro-mvp]

Updated

6 years ago
Whiteboard: [metro-beta][metro-mvp] → [metro-mvp]
Duplicate of this bug: 801030
No longer depends on: 784042
No longer depends on: 794033
No longer depends on: 793515

Updated

6 years ago
No longer depends on: 797180
Whiteboard: [metro-mvp] → [metro-mvp][LOE:-]
Depends on: 808759
Depends on: 811429
Depends on: 801000
Depends on: 808770
Summary: [Tracking] Support new start screen with top sites, bookmarks, recent history, downloads → [Tracking] Support new start screen with top sites, bookmarks, recent history, downloads, synced tabs
Depends on: 812291

Updated

6 years ago
Depends on: 812530
Depends on: 816256
Depends on: 830505

Comment 10

5 years ago
The Awesome screen is the Metro Firefox user's starting point when she launches Firefox or opens a new tab. This group of stories covers the primary interactions with the Awesome screen.
Assignee: nobody → asa
Summary: [Tracking] Support new start screen with top sites, bookmarks, recent history, downloads, synced tabs → Awesome screen
Whiteboard: [metro-mvp][LOE:-] → epic [metro-mvp][LOE:-]

Updated

5 years ago
Hardware: x86_64 → x86
Depends on: 831866

Updated

5 years ago
Depends on: 831915

Updated

5 years ago
Depends on: 831916

Updated

5 years ago
Depends on: 831917

Updated

5 years ago
Depends on: 831918

Updated

5 years ago
Depends on: 831919

Updated

5 years ago
Depends on: 831920

Updated

5 years ago
Depends on: 831922

Updated

5 years ago
Depends on: 831923

Updated

5 years ago
Priority: -- → P1

Updated

5 years ago
Blocks: 831997

Updated

5 years ago
Priority: P1 → --

Updated

5 years ago
Depends on: 832105

Updated

5 years ago
Whiteboard: epic [metro-mvp][LOE:-] → feature=epic

Updated

5 years ago
Summary: Awesome screen → Epic - Awesome Screen

Updated

5 years ago
No longer depends on: 794064

Updated

5 years ago
No longer depends on: 808770

Updated

5 years ago
Depends on: 808770

Updated

5 years ago
No longer depends on: 831917

Updated

5 years ago
Depends on: 803925

Updated

5 years ago
No longer depends on: 831866

Updated

5 years ago
No longer depends on: 830505

Updated

5 years ago
No longer depends on: 808770

Updated

5 years ago
No longer depends on: 812291

Updated

5 years ago
No longer depends on: 832105

Updated

5 years ago
No longer depends on: 794030

Updated

5 years ago
No longer depends on: 812530

Updated

5 years ago
No longer depends on: 801056

Updated

5 years ago
No longer depends on: 801000

Updated

5 years ago
No longer depends on: 791914

Updated

5 years ago
No longer depends on: 816256

Updated

5 years ago
No longer blocks: 782867

Updated

5 years ago
No longer depends on: 811429

Updated

5 years ago
No longer depends on: 785037

Updated

5 years ago
Depends on: 831937

Updated

5 years ago
Summary: Epic - Awesome Screen → Epic - Firefox Start

Updated

5 years ago
No longer depends on: 831919

Updated

5 years ago
Blocks: 841999
No longer blocks: 831997

Updated

5 years ago
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: Trunk → ---
Depends on: 845911

Updated

5 years ago
No longer depends on: 794028

Updated

5 years ago
No longer depends on: 845911

Updated

5 years ago
Depends on: 831934
Depends on: 850737
No longer depends on: 864408

Updated

5 years ago
Depends on: 865714

Updated

5 years ago
Depends on: 867754

Updated

5 years ago
Depends on: 867616
Depends on: 872243

Updated

5 years ago
No longer depends on: 872243

Updated

5 years ago
Depends on: 872243

Updated

5 years ago
No longer depends on: 877875

Updated

5 years ago
No longer depends on: 879113

Updated

5 years ago
No longer depends on: 872243

Updated

5 years ago
Depends on: 892512

Updated

5 years ago
No longer depends on: 865714

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
No longer depends on: 905369

Updated

5 years ago
Assignee: asa → nobody

Updated

4 years ago
No longer depends on: 867754
Depends on: 964140
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.