Closed Bug 747791 Opened 8 years ago Closed 8 years ago

Drawing inside canvas is not bound by iframe box

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 728026
Tracking Status
blocking-fennec1.0 --- +

People

(Reporter: martijn.martijn, Assigned: joe)

References

()

Details

(Keywords: regression, testcase)

See url testcase, steps to reproduce:
- Make some swipe movements inside the top iframe and then move outside the iframe

Expected result:
- The black lines that are drawn are bound by the iframe box

Actual result:
- The black lines are drawn also outside the iframe box

I couldn't reproduce this bug in a 2012-03-13 trunk build, but I can see this bug in a 2012-03-15 trunk build.

So I think this is a regression from the Maple branch landing (bug 725095).

Tested on the Samsung Galaxy Nexus.
Sound similar, but this one is permanent, while bug 741173 happens only while panning.
Depends on: 741173
blocking-fennec1.0: --- → ?
adding Wes for touch events
Assignee: nobody → joe
blocking-fennec1.0: ? → +
This is fixed by my patch in bug 728026.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 728026
You need to log in before you can comment on or make changes to this bug.