Closed Bug 747792 Opened 8 years ago Closed 8 years ago

Preventdefault doesn't work for touch events from inside iframe

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- fixed
firefox15 --- verified
blocking-fennec1.0 --- +

People

(Reporter: martijn.martijn, Assigned: wesj)

References

()

Details

(Keywords: regression, testcase)

Attachments

(1 file)

See url, inside the black bordered box inside the iframes, just make some swipe movements.

Notice how the page moves inside Fennec. That should not be happening.

Also pinch zoom gestures shouldn't have any effect other than that black lines are drawn inside the black bordered box.

Tested on the Samsung Galaxy Nexus.

This works at least in a 2012-03-15 trunk build.

Also, notice how drawing lines in the top iframe are not bound by the iframe box, which it should. But this is a different bug. I filed bug 747791 for that.
Last good build: 03/09

Bad build: 03/10

Possible regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9ca66ce2672f&tochange=7702bca6b64d

--
Device: HTC Desire Z
OS: Android 2.3.3
Regression from bug 742019?
soft blocker?
tracking-fennec: --- → ?
blocking-fennec1.0: --- → ?
Kats - If you think this shouldn't block, just renom and comment
Assignee: nobody → bugmail.mozilla
blocking-fennec1.0: ? → +
Attached patch PatchSplinter Review
Easy fix
Assignee: bugmail.mozilla → wjohnston
Attachment #621173 - Flags: review?(mark.finkle)
To explain the problem, we weren't notifing java of the listeners, so it allowed panning.

With our new touch handler, once we've started giving events to the touch handler we don't give the page another chance to stop prevent panning. We did that on purpose because trying to start and stop panning after the page responds leads to confusing situations for the user (and our backend)
Comment on attachment 621173 [details] [diff] [review]
Patch

I can r+ this, I suspected it was something like this but hadn't started looking for the relevant line of code yet :)
Attachment #621173 - Flags: review?(mark.finkle) → review+
Comment on attachment 621173 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): bug 742019 made it visible. always present
User impact if declined: iframes will not be able to prevent panning.
Testing completed (on m-c, etc.): landed on mc March 4
Risk to taking this patch (and alternatives if risky): Very low risk. Samll change for correctness, and I haven't seen this on real sites ever.
String changes made by this patch: None.
Attachment #621173 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d7e560c39dc3
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Comment on attachment 621173 [details] [diff] [review]
Patch

[Triage Comment]
Very low risk and blocking FN1.0. Approved for Aurora 14.
Attachment #621173 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I verified this for trunk.
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.