Last Comment Bug 747827 - Add a way to reflect typed arrays in the new DOM bindings
: Add a way to reflect typed arrays in the new DOM bindings
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Boris Zbarsky [:bz]
:
Mentors:
: 742209 (view as bug list)
Depends on: 742217
Blocks: 745897 749864
  Show dependency treegraph
 
Reported: 2012-04-22 22:04 PDT by Boris Zbarsky [:bz]
Modified: 2012-05-10 21:02 PDT (History)
2 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add some structs that can be used to represent typed arrays in DOM bindings. (4.35 KB, patch)
2012-04-22 22:06 PDT, Boris Zbarsky [:bz]
peterv: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] 2012-04-22 22:04:58 PDT
This is just the data structure so far; the codegen bits are still to come.
Comment 1 Boris Zbarsky [:bz] 2012-04-22 22:06:08 PDT
Created attachment 617387 [details] [diff] [review]
Add some structs that can be used to represent typed arrays in DOM bindings.
Comment 2 Peter Van der Beken [:peterv] - away till Aug 1st 2012-04-24 02:40:21 PDT
So we don't want/need to expose a way to get the data correctly typed based on the underlying array from ArrayBufferView?
Comment 3 Boris Zbarsky [:bz] 2012-04-24 09:30:44 PDT
Not yet; WebGL doesn't need it.

Given DataViews, it's not quite clear what "correctly typed" would even mean in general for ArrayBufferView.  Things that want to take some subset of ArrayBuferViews that happen to be actual typed arrays should be using overloads in the IDL, I would think.
Comment 4 Boris Zbarsky [:bz] 2012-04-24 09:31:50 PDT
And note that in extreme corner cases the callee does have the JSOject*.
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-05-05 03:39:23 PDT
https://hg.mozilla.org/mozilla-central/rev/41e810dd264f
Comment 7 Boris Zbarsky [:bz] 2012-05-10 21:02:22 PDT
*** Bug 742209 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.