Last Comment Bug 747856 - Add Win 64 bit mozconfigs and fix Mac universal mozconfigs
: Add Win 64 bit mozconfigs and fix Mac universal mozconfigs
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Build Config (show other bugs)
: 13 Branch
: x86 Mac OS X
: -- normal (vote)
: Thunderbird 14.0
Assigned To: Mark Banner (:standard8)
:
Mentors:
Depends on:
Blocks: 698843 747025
  Show dependency treegraph
 
Reported: 2012-04-23 02:21 PDT by Mark Banner (:standard8)
Modified: 2012-04-25 02:31 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
13+
fixed


Attachments
The fix (9.47 KB, patch)
2012-04-23 02:21 PDT, Mark Banner (:standard8)
jhopkins: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑esr10+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2012-04-23 02:21:03 PDT
Created attachment 617426 [details] [diff] [review]
The fix

Now that bug 747025 is getting in full flow, we're starting to get builders out and running.

From the nightlies we've had running so far, we need:

- Win64 bit mozconfigs (although these aren't going to be official builds yet, having some trunk ones is what we want to match with FF and aid any development work).
- Adjust Mac universal mozconfigs. The issue here is that the mozilla/ sub-directory isn't available when these are needed. Therefore we need to copy across from the Firefox directory the bits we need, this also allows us to remove most of the hacks that we've needed for the different location according to topsrcdir.

In the Win64 mozconfigs, I've had to do a bit of a hack again as the vs2010-mozconfig isn't in a common directory. I'm going to file a bug on making that common (i.e. in a build/ subdir), and when we do, we can do the same in c-c.

I'll take whoever gets to the review first.
Comment 1 Mark Banner (:standard8) 2012-04-23 02:35:37 PDT
(In reply to Mark Banner (:standard8) from comment #0)
> In the Win64 mozconfigs, I've had to do a bit of a hack again as the
> vs2010-mozconfig isn't in a common directory. I'm going to file a bug on
> making that common (i.e. in a build/ subdir), and when we do, we can do the
> same in c-c.

Bug 747860 raised.
Comment 3 Mark Banner (:standard8) 2012-04-23 13:45:23 PDT
Comment on attachment 617426 [details] [diff] [review]
The fix

[Triage Comment]
Also going to take these currently NPOTB parts across to aurora as we'll need them over there as well.
Comment 5 Mark Banner (:standard8) 2012-04-25 02:26:27 PDT
Comment on attachment 617426 [details] [diff] [review]
The fix

[Triage Comment]
Need to sync this to ESR so that we can run the new build systems there as well.

Note You need to log in before you can comment on or make changes to this bug.