Closed Bug 747935 Opened 8 years ago Closed 5 years ago

Content goes blank on this SVG page after double tapping on the right side of it

Categories

(Firefox for Android :: Toolbar, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:
- Go to http://dl.dropbox.com/u/7742672/FirefoxLayersSVG.svg
- Pinch zoom on the right side of that page
- Double tap somewhere on the right

Expected result:
- Some part of the page shown

Actual result:
- Completely blank page

I'm not seeing this in the latest Aurora build, so I guess this is a regression. I'll look for a regression range later today (if nobody else does).
Here are my findings so far:
March 1st - double tap does not work
March 10th - double tap does not work
March 11th - checkerboard
March 13th - checkerboard
March 14th (maple merge) - fail – img inverted on double tap with negative coordinates.
March 15th - fail 
March 31st – fail – grey screen not white
April 24th – fail – white screen

The view goes white because the coordinates are inverted. I have seen the issue by doing an overscroll to reveal the top-left margins of the svg. This was easier to see when the checkerboard background was black - at the time of the maple merge ( see the screenshot) - but it can be seen now if you overscroll to the maximum possible position.

I will continue to try and bisect maple builds for the regression range.
A small correction: I said in Comment 1 that the coordinates are inverted. They are actually negated not inverted.

In the maple branch the build bisect:
march 7 - pan is not possible view jumps – issue is not reproducible
march 8 - pan is not possible view jumps – issue is not reproducible
march 12 e88141f7f64c -  pan is not possible view jumps – issue is not reproducible
march 12 e3798e906917 – issue reproducible 
march 13 – issue reproducible

regression range: http://hg.mozilla.org/projects/maple/pushloghtml?fromchange=e88141f7f64c&tochange=e3798e906917

This never actually worked correctly on maple. Before March 12th panning was impossible. The view jumped back to the left part of the screen. On the second maple build from 2012-04-12 the current issue was introduced and the old behavior was fixed.
Component: General → Graphics, Panning and Zooming
Wfm on latest nightly
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.